x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Imported FBX animation doesn't work in 4.10.1

I have a skeletal mesh with an animation that I have exported from my CG app (modo) as two separate FBX files (one for the mesh, one for the animation). I am able to import the skeletal mesh and the animation just fine in 4.9.2 and the animation works correctly.

However, when I import the same FBX files into 4.10.1, the animation does not work. I can import the skeletal mesh, but when I import the animation file and associate it with my skeleton, the mesh is not animated when previewing. The bones and frames are present, but the mesh does not animate.

I have tested the FBX files in the Autodesk FBX Viewer and they work fine.

The files are attached.

Thanks

link text

Product Version: UE 4.10
Tags:
fbx.zip (35.2 kB)
more ▼

asked Dec 27 '15 at 05:17 PM in Bug Reports

avatar image

TKStackMoney
6 1 3 5

avatar image randallelliott Jan 05 '16 at 05:20 PM

im having this same problem, my animation plays in 4.9 but not in 4.10...i tried changing the rotation order in modo to xyz but it still wont play...hopefully i can just export my input mappings and copy all my assets from the 4.10 content folder and paste it into the 4.11 new project....that should be ok?

avatar image Matt.Williams Jan 05 '16 at 06:38 PM

Hi randallelliott,

If changing to XYZ did not fix your problem, then it is a different problem. Please open a new Answerhub thread.

-Matt W.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey VrindiTim,

It appears that your rotation order on your joints is ZXY, a bug with importing ZXY joints was discovered recently and is in our system as UE-24519. For now, try different joint rotation orders until we can get this fixed.

Not sure if rotation order is called something else in Modo, but you might want to look under anything to do with Gimbal Lock.

-Matt W.

more ▼

answered Dec 28 '15 at 09:13 PM

avatar image TKStackMoney Dec 29 '15 at 01:05 AM

Hi, thanks for the information. Based upon you input, I re-exported my animation using ZYX rotation order. The animation worked in Autodesk FBX viewer, but when I tried to import into UE4 it crashed the editor. I have noticed several other bug reports related to FBX import in 4.10, so for now I will just use 4.9.2 until the FBX bugs are squashed in a future update.

avatar image TKStackMoney Dec 29 '15 at 03:07 AM

One more quick update. I changed the rotation order to XYZ and the animations now work correctly in 4.10.1.

avatar image Matt.Williams Dec 29 '15 at 07:14 PM

Just wanted to note, I was making test assets to add to the existing bug and decided to check it out in 4.11. The crash with ZYX and the original issue with ZXY seem to be resolved in 4.11. I also tested all other rotation orders and they appear to work as expected.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question