x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.11 Preview 1 Source Build Crashes on Load.

For some reason, I can't load my (previously 4.10) project in a 4.11 Source-Code build of the engine. I haven't made any modifications to the engine, all I have done is modify a shortcut to 'Setup.bat' so I can pass in the following commandline options (and save myself a 4gb download that I don't need). I have also modified gitdeps.xml so that it doesn't download any of the Sample / Template content.

-exclude=Linux -exclude=IOS -exclude=Android -exclude=HTML5 -exclude=Linux32 -exclude=osx64

Whenever I try to load my project in this new engine version, I get the following error in the Output Window and a Crash.

Tried to get module interface for unloaded module: 'FoliageEdit'

I have made NO modifications to the editor, nor am I even using Foliage anywhere in my project. Here is the callstack:

 >    UE4Editor-UnrealEd.dll!FModuleManager::GetModuleChecked<IFoliageEditModule>(const FName ModuleName) Line 240    C++
      UE4Editor-UnrealEd.dll!FModuleManager::LoadModuleChecked<IFoliageEditModule>(const FName ModuleName) Line 285    C++
      UE4Editor-UnrealEd.dll!FEditorModeRegistry::Initialize() Line 61    C++
      UE4Editor-UnrealEd.dll!FUnrealEdMisc::OnInit() Line 229    C++
      UE4Editor-UnrealEd.dll!EditorInit(IEngineLoop & EngineLoop) Line 86    C++
      UE4Editor.exe!GuardedMain(const wchar_t * CmdLine, HINSTANCE__ * hInInstance, HINSTANCE__ * hPrevInstance, int nCmdShow) Line 133    C++
      UE4Editor.exe!WinMain(HINSTANCE__ * hInInstance, HINSTANCE__ * hPrevInstance, char * __formal, int nCmdShow) Line 189    C++
 

And attached is the log. It seems to Unload the module for some reason then tries to access it?link text

Product Version: UE 4.11 Preview
Tags:
log.txt (79.7 kB)
more ▼

asked Dec 28 '15 at 03:59 PM in Bug Reports

avatar image

TheJamsh
815 57 96 140

avatar image TheJamsh Dec 28 '15 at 10:05 PM

I've just completely re-downloaded and re-built the engine, complete with all the stock files and settings. No modifications, just pure 4.11 Preview 1.

Still getting the same crash. This is ridiculous... it's as if the OS cannot actually load the .dll at all (I checked, it does exist!)

avatar image TheJamsh Dec 28 '15 at 10:51 PM

Just tried to open in Binary (Launcher) version of the engine. STILL occurring.

avatar image Matthew J Dec 29 '15 at 04:31 PM

Hello TheJamsh,

Is this only happening with a particular project or any project you convert from 4.10.1 to 4.11 Preview 1? I'm not having any success having it happen on my end with the 4.11 preview source or binary versions.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I think figured out a workaround. In my .uproject file was a massive array of plugins, all of which were set to false as I don't use any engine plugins. I just deleted that array and it worked fine. As I already said, I don't use any engine plugins, but if you do, this might be a problem.

more ▼

answered Jan 09 '16 at 03:27 AM

avatar image

vibgyorc6
75 12 19 25

avatar image jeffvoigt Mar 16 '16 at 10:38 PM

It is specifically the LightPropagationVolume plugin. I disabled it as well and it crashed. I edited the uproject file and turned it back on and it was fine =(

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

We haven't heard from you in a while, TheJamsh. Are you still experiencing these issues? If so, can you give a fresh project a try if you haven't to see if the same errors occur? I'll be marking this as resolved in the meantime for tracking purposes.

more ▼

answered Jan 04 '16 at 03:50 PM

avatar image vibgyorc6 Jan 06 '16 at 01:24 AM

I'm having the same problem with my project, however I am using foliage. I'm using the launcher version. My project was upgraded from 4.10.1, also from the launcher. Here's my log file: http://pastebin.com/T0S9vfGT

avatar image Matthew J Jan 07 '16 at 03:47 PM

Hello vibgyorc6,

Are you only experiencing this issue with your particular project or any project that is converted from 4.10.1 to 4.11? I'd be interested to know if it is a project specific issue or a general conversion problem.

avatar image vibgyorc6 Jan 07 '16 at 05:20 PM

It seems to be project specific. I created a new code project from 4.10.1 and converted it to 4.11 and it didn't crash. I did find another bug, though. I had to change GENERATED_BODY() to GENERATED_UCLASS_BODY() because it kept producing compiler errors, which is strange because I converted another code project that was made with 4.9 I think (it's another test project that was made along time ago) that used GENERATED_BODY() everywhere and there was no compiler errors. The old project was based on the third-person shooter template and the new one was just a blank code project. Neither of them crashed and/or had trouble with the FoliageEdit module.

avatar image Matthew J Jan 07 '16 at 08:07 PM

It seems like there are issues with the .uassets themselves in the conversion process. The log is filled with problems related to not being able to load assets. Can you try migrating the content over from the 4.10.1 project to a fresh 4.11 project to see if the same issue occurs?

avatar image vibgyorc6 Jan 07 '16 at 10:43 PM

I copied my entire content folder over to a fresh project made with 4.11 and even copied my game's source code and compiled it and both times I had no luck reproducing the crash. The test project didn't have any trouble loading assets, but it understandably couldn't compile my blueprints as I had changed all the class names in my source code for the test project. It seems like it was able to load them anyways.

avatar image grisevg Apr 14 '16 at 12:46 PM

This crash happens if you disable LightPropagationVolume plugin. Happens for me on 4.11.0 and 4.11.1

avatar image Matthew J Apr 14 '16 at 03:34 PM

Hello Grisevg,

Thank you for clearing that up. We currently have a bug in our system for not being able to disable this plugin without crashing the editor.

Have a nice day!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question