x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Error when packaging for Android (GearVR)

Hi,

Before I start to build anything too serious I thought I'd do a quick test package build to make sure I have everything in order. I've followed a couple of quick start tutorials for setting up a GearVR project and followed them to the letter. I've tried both Blueprint and C++ and get the same result..."BUILD FAILED"

I'm using Unreal 4.10.1

I'm sure this will be something simple but I'm much more artist than coder and I'm just going round in circles. Any assistance will be much appreciated.

I've attached two screen grabs of my settings and a copy of the output log.

Thanks

Paul

link text

Product Version: UE 4.10
Tags:
android_sdk.jpg (94.7 kB)
android.jpg (271.6 kB)
ouput_log.txt (333.2 kB)
more ▼

asked Dec 29 '15 at 01:34 AM in Packaging & Deployment

avatar image

carbondigital
21 2 2

avatar image Rudy Q ♦♦ STAFF Jan 04 '16 at 09:21 PM

Hello carbondigital,

I noticed that you said you have looked over some quick start guides, however I wanted to make sure that you have taken a look at our official documentation. I have provided a link to this information below. I hope that this helps.

Link: https://docs.unrealengine.com/latest/INT/Platforms/GearVR/QuickStart/1/index.html

If this information does not help please answer the questions below.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?

  3. Could you provide screen shots of your project settings that relate to setting up the project for Gear VR (other than those that have been provided)?

avatar image carbondigital Jan 06 '16 at 09:02 PM

Hi Rudy,

Thanks for your reply. I've actually followed that official guide step by step. I've tried doing both ways...Blueprint and C++.

I've tried different project types...blank, first person, rolling, vehicle and get the same result.

The steps I take are exactly as the official documentation then when I go to package the project I set it for Android ECT2.

The frustrating this is that I downloaded Unity 5 to check if perhaps there was something missing from my installation with the NVPack or Visual Studio and when I set up a simple project and exported it, it connected straight to my phone and uploaded the package. I don't want to use Unity though!!!

I've attached screen grabs from my settings and my output log.

Any help will be much appreciated.

Thanks

Paul

alt text

output_log.txt (1.2 MB)
android.jpg (143.3 kB)
android_sdk.jpg (44.7 kB)
plugins.jpg (80.4 kB)
avatar image Rudy Q ♦♦ STAFF Jan 07 '16 at 06:40 PM

I was looking through the logs that you linked and I noticed the line mentioned below. Could you double check your setting for your Android SDK? The file paths may not be correct.

Line: "MainFrameActions: Packaging (Android (ETC2)): Perhaps JAVA_HOME does not point to the JDK."

avatar image Rudy Q ♦♦ STAFF Jan 11 '16 at 07:17 PM

Hello carbondigital,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

avatar image carbondigital Jan 11 '16 at 07:33 PM

Hi Rudy,

Unfortunately I haven't yet resolved this issue. I have followed the official guide to the letter and got exactly the same result.

I decided that I'd install Unreal on my macbook pro and try getting a result that way. Again I followed the guide, step by step, installing Unreal, android sdk, jave etc. Still no joy. It's driving me mad!

I'll send screen grabs and output log for you to look over.

Thanks

Paul

avatar image Rudy Q ♦♦ STAFF Jan 12 '16 at 06:24 PM

Hello carbondigital,

Is it possible for you to package for any platform successfully? For example can you package for windows?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Rudy,

A friend sent a link to me today and I did what it suggests. It worked!

Job done :)

Thanks

Paul

https://answers.unrealengine.com/questions/294430/packaging-for-android-fail-on-49-was-working-on-48.html

more ▼

answered Jan 12 '16 at 09:29 PM

avatar image

carbondigital
21 2 2

avatar image Rudy Q ♦♦ STAFF Jan 13 '16 at 01:52 PM

I am happy that you were able to fine a solution to your issue. I will be converting your last comment to an answer. If this problem returns please feel free to update this thread with any additional information you may have.

Make it a great day

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question