x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Colors getting lighter/grey/washed out when scene is built.

Hey, I have a scene that I've been working on for a while, a landscape with a texture and some water.. nothing too exciting yet. In the preview everything looks fine, if I start playing the game it's still looking good except that the textures seem to have tiling. So my friend advised that I should rebuild the lights, when I did the whole landscape became grey and washed out. I tried turning off all lights but it didn't solve anything. I have a movable light source, movable skylight, atmospheric fog and a skysphere.. basically everything that comes with the 3d shooter starter content - I just messed around with their settings. 1st image is the ingame view, it looks like this in builder mode also, 2nd image is where you can see the tiling. Third image - I clicked build. Any help would be appreciated.

Danielalt text alt text

alt text

Product Version: UE 4.9
Tags:
more ▼

asked Dec 31 '15 at 05:59 PM in Bug Reports

avatar image

ssssskull
1 1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

This seems like a settings that's been changed somewhere that could cause this to happen, but I'm not sure exactly what at the moment. More than likely this isn't a bug though.

There's a couple of things I want you to try first:

  • The tiling issue seems like it may be with your material that you've got applied to your landscape. Try just applying a simple white material (Use a constant value of 1 in your material plugged into your diffuse color) and apply that to the landscape. If the issues is gone, that clearly points to your material for the landscape. If not, then it could be something else, but we'll look at that later.

  • The gamma issue. In the viewport go to the Show > Post Process > and then start unchecking the boxes here one by one until you see a change. This can rule out if something were changed in the post process volume in your scene.

  • If that didn't do anything, try removing the Skylight from the scene. Rebuilt lighting afterwards, although this really shouldn't matter since you're using Movable lights and skylights.

  • If that doesn't work, select your Movable Directional Light and in it's Details Panel uncheck the option for "Affect World". This won't delete the light but just make it not work for the moment. Then add in a point light and increase it's radius to a larger value along with the intensity and set it to Movable. Is it still not lighting correclty?

If you're using any other lighting features, such as Distance Fields, Light Propagation Volumes, or can reproduce this in a new map/Project that would be helpful to know as well.

Thank you!

Tim

more ▼

answered Dec 31 '15 at 06:29 PM

avatar image

Tim Hobson ♦♦ STAFF
48.7k 888 103 880

avatar image ssssskull Dec 31 '15 at 09:36 PM

Alright, I got rid of the tiling, it was a LOD setting, when I changed the light source to movable it reset it to -1. So that's fixed, but the weird gamma thing is still there. I tried unchecking every post process but there was barely any difference. Since then I accidentally saved and can't really get back to its original state. I used an older save and made the SkyLight movable. When i did that I got the same result, everything looked nicer. So i was praying it'd stay like that when building. When it finished building it did the same thing again. It's not any of the post-process features. When I added a point light and changed the values it wasn't visible at all. Thanks in advance, Danielalt text

[2]: /storage/temp/72474-01b3a1fc231d54e5ac7225059849e59b.png

avatar image Tim Hobson ♦♦ STAFF Jan 04 '16 at 06:51 PM

Thanks for getting back to me. Were you able to try this in a new project, or make a copy of your project and see if the issue persists in 4.10?

One other thing I can think of is can you go to your Project Folder > and delete/move to another location the Saved, Config, and Intermediate folders? Sometimes there are files here that save changes or get corrupted that I've seen that removing this can correct an issue.

If this doesn't work, I'll need to you to reproduce this on a separate new level in your project to see if this persists, if so then I need you to try in a new blank project with a default level. This is needed to remove any content issues that may be with that specific level. If I'm not able to reproduce this in a new project it will be near impossible for a developer to do so to potentially resolve any issue that may be going on.

Thanks for your efforts, it is really appreciated!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question