x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

installing ue4 on mac from source code

i try to install ue4 on my mac i have to file that could be running throu terminal setup.command and GenerateProjectFiles.command and after i ran this files i get the following errors :

Last login: Sat Jan 2 01:20:50 on ttys000 Masouds-MacBook-Pro:~ Masoud$ /Users/Masoud/Desktop/unreal/engine/GenerateProjectFiles.command ; exit;

Setting up Unreal Engine 4 project files...

Setting up Mono Cannot open assembly '/Users/Masoud/Desktop/unreal/engine/Engine/Build/BatchFiles/Mac/../../../Binaries/ThirdParty/Mono/Mac/lib/mono/xbuild/12.0/bin/xbuild.exe': No such file or directory. UnrealBuildTool Exception: System.IO.FileNotFoundException: Could not load file or assembly 'System.Xml.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. File name: 'System.Xml.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' at UnrealBuildTool.UnrealBuildTool.Main (System.String[] Arguments) [0x00000] in :0 logout

i ran the same source code on windows 7 using vs2013 and it's working just fine

Product Version: UE 4.10
Tags:
more ▼

asked Jan 04 '16 at 03:36 AM in Installation & Setup

avatar image

masoudx7
1 2

avatar image UNTITLED - Project Apr 21 '17 at 10:49 AM

this is probably going to sound silly - but i opened the setup.command and did the generateprojectfiles.comand - but i cant find the UE4.xcworkspace file to load into xcode

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey masoudx7,

You mention you went through the correct steps, but you also mention the use of the terminal. There is a different process when using strictly the terminal.app versus simply running the Setup.command and the GenerateProjectFiles.command.

Would you mind following along with the steps written on GitHub when compiling source code for Macs, and let me know which step you encounter an error?

alt text

I just followed the steps myself and did not have any trouble opening up the UE4.xcworkspace in Xcode. The steps mention using the latest version of Xcode which is 7.2, but I was able to build the engine using 7.1.1 just fine.

It is usually a good idea to remain up to date anyway, so if you are behind version 7.1.1 I would go ahead and update. On that note, we have moved on to support Visual Studio 2015 as well.

One thing to try for you issue, is to re-download the source zip folder from GitHub, and extract it to your desktop. Then run the commands from there to see if that works.

If you have questions or get stuck let me know.

Cheers,

Andrew Hurley

snip20160105_1.png (150.0 kB)
more ▼

answered Jan 05 '16 at 03:14 PM

avatar image kalmiya Aug 06 '16 at 04:45 PM

I ran into the same issue when tying to compile ShaderCompileWorker. My mistake was running ./Setup.sh from the terminal ( I ignored the other files, as I didn't know you could run .command files). Reading AndrewHurley's post more carefully I noticed the difference and ran the Setup.command from within finder ( by doubleclicking ) and that works.

avatar image UNTITLED - Project Apr 21 '17 at 10:52 AM

this is probably going to sound silly - but i opened the setup.command and did the generateprojectfiles.comand - but i cant find the UE4.xcworkspace file to load into xcode - can you help me out here at all?

avatar image AndrewHurley Apr 21 '17 at 03:36 PM

Have you read over the post I provided above, to make sure you are following the correct steps in case you are using a GitHub source build?

Would you happen to be able to walk me through your process, so I can see maybe where you are going wrong?

Cheers,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question