x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to scale a blueprint properly?

Sounds silly, but I want to scale blueprints with static mesh component... And instead of scaling with stretching (like regular static meshes) it scales every StaticMesh component in his local axis. Here's the problem:

alt text

This is a blueprint with 2 rotated static mesh components inside. What I need to do to be able to scale blueprints like these so they behave like regular static meshes when scaling? So e.g. I don't want to cross these 2 meshes like in the image, but to stretch them up. I hope you'll understand what I mean.

Product Version: UE 4.10
Tags:
untitled-1.jpg (337.0 kB)
more ▼

asked Jan 02 '16 at 02:14 AM in Blueprint Scripting

avatar image

Slavq
2k 157 153 209

avatar image Shadowriver Jan 02 '16 at 03:15 AM

What doi you use for scaleing now? also you mean Actor not Blueprint :p

avatar image Slavq Jan 02 '16 at 01:39 PM

I use a standard Scale gizmo with blue handle (Z), or just type e.g. "1.5" in Z axis under Transform panel - and it behaves like that, scaling each StaticMesh component along its LOCAL axis, instead of treating a whole Actor as one.

avatar image Slavq Jan 02 '16 at 04:39 PM

Update: I've tried with different static meshes and all of them have this problem - scaling along their local Z axis instead of Z axis of the owner.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I attach this link just to make it sure we tryed every thing. https://docs.unrealengine.com/latest/INT/Engine/Actors/Transform/index.html try to select these 2 options. i am running out of solutions :P alt text

immagine.png (201.6 kB)
more ▼

answered Jan 02 '16 at 06:57 PM

avatar image

Est_engine
1.2k 58 12 62

avatar image Slavq Jan 02 '16 at 07:08 PM

I've tried it but nothing changed :D Well, probably my UE editor is trolling me or something... No idea why it behaves this way, especially while yours seems to work ok. Anyway, I've found a workaround (I just use Spline Meshes with start/end point) so it's ok now. Thanks, I'll accept your answer to give you some points for trying to help :) Cheers!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi man , i dont know what is wrong in your settings. Here i can make a Actor , add 2 static mesh rotate them as a "A" And when i scale my Actor , the static meshes scale perfectly , keeping the A shape.

Here all is scaled as is one object. you got every static mesh scaled on his own.

more ▼

answered Jan 02 '16 at 12:22 PM

avatar image

Est_engine
1.2k 58 12 62

avatar image Slavq Jan 02 '16 at 01:42 PM

alt text

Here is how it looks. Two rotated static meshes - and it scales them along their local axis each, instead of forming a stretched "A"

bez tytułu.jpg (105.4 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question