x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Continuous Audio Playback

I want to have my music to appear as though it's being projected from a screen. There are three songs in my audio file and it's all working as far as file types etc goes.

However, if i walk away from the sound, obviously it goes quiet and then silent but it also stops completely and when i return to a closer position again, the music starts from the beginning. I wan't the music to have continued playing to itself whilst i'm not there and when i return i can hear the music again at whatever point it's got to based on the time that i've been away.

It's simple but i'm finding it hard to describe. Someone please help me out!alt text

Product Version: UE 4.9
Tags:
nodee.jpg (906.3 kB)
more ▼

asked Jan 04 '16 at 06:48 PM in Using UE4

avatar image

BurtonM8
11 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi, you might want to check out this answer to a similar problem.

Basically: assign a Sound Class to your sound and set it to "always play" - a possible alternative being to keep track of the time yourself and setting the start time of the sound you're playing accordingly.

more ▼

answered Jan 06 '16 at 08:42 PM

avatar image

G4m4
695 27 15 34

avatar image BurtonM8 Jan 07 '16 at 03:17 PM

thanks so much mate, people saying it works on that post you linked! I've got a SoundClass node in my sound cue blueprint but no sign of the 'always play' box. Any chance at all you could screen shot what i need to do?

Sorry if its obvious im completely new to all this aha

avatar image G4m4 Jan 07 '16 at 03:57 PM

No worries!

First you have to create a sound class asset, and assign it to your SoundCue - that's somewhere in the sound cue details:

SoundCue

Then you set the "Always Play" in the Sound Class details:

SoundClass

sound_cue.png (7.3 kB)
sound_class.png (10.6 kB)
avatar image BurtonM8 Jan 07 '16 at 03:49 PM

FIXED IT. Thanks so much again mate!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

someone please help me

more ▼

answered Jan 06 '16 at 07:34 PM

avatar image

BurtonM8
11 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question