x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Light source inside a object?

It's a bit hard to explain, so here is image of what I have done:

Image

The outer sphere is partially transparent and uses emissive color, inside it there is a smaller non transparent sphere and a point light source inside it. I tried to use the emissive color to light the scene and cast shadows, but no luck (maybe I did something wrong?) Then, I have added a point light and looks like the inner sphere is blocking the light from the point light source.Ow, ...this is a movable object,

How can I get a movable sphere which will be able to light objects near it and cast shadows? Should I just add some large amount of light sources around the sphere?

Product Version: UE 4.10
Tags:
untitled-4.jpg (103.8 kB)
more ▼

asked Jan 06 '16 at 12:34 PM in Using UE4

avatar image

Naivrat
50 9 9 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Emissive materials do not illuminate the scene in UE4 (this would require global illumination, GI, which is an incomplete high-end feature). Your best bet to achieve this effect is to use a point light within your mesh, like you described.

Try and see if 'Cast Shadows' is disabled for your EnergyCell meshes. If there is a light source inside of a mesh that is set to cast shadows, then that light source will probably be invisible to the rest of the scene or have lighting artifacts, because the mesh around it is blocking it.

Also, if you are placing a light source to intersect or be inside of a mesh, make sure the light source radius property is set to 0, otherwise you will see lots of lighting artifacts.

You should also increase the light source parameter 'Min Roughness' to a number like 0.9. This will help make your point light source look like it is larger and softer.

more ▼

answered Jan 06 '16 at 02:17 PM

avatar image

cancel
2.4k 101 72 124

avatar image Naivrat Jan 06 '16 at 02:30 PM

Thanks for your reply! Actually the problem was because of "double sided" material on the inner sphere :) I'll mark your's answer as correct one, because the things you have suggested helped me to make the light more realistic :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question