x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Menu Widget Won't Go Away 4.10

Hi everyone,

I followed countless tutorials online about making menus. I was informed that they changed the name from "Remove from Viewport" or something like that to "Remove from parent". I have it lined up, and when I hit play, the widget appears like it should, but when I click the widget, it does not go away. What am I missing? I followed the Unreal tutorial as well... Please help.

Product Version: UE 4.10
Tags:
more ▼

asked Jan 07 '16 at 04:00 AM in Blueprint Scripting

avatar image

Faiberglas
6 1 2 2

avatar image Sean L ♦♦ STAFF Jan 07 '16 at 04:03 PM

Hello,

Could you please provide a screenshot of your blueprint? I'd like to see how you have it set up.

avatar image Faiberglas Jan 07 '16 at 10:20 PM

Hello and thanks for the help,

This is what I have for the button.

alt text

buttonblueprint.jpg (421.4 kB)
avatar image FiftyStars Jan 08 '16 at 07:03 AM

Does this event fires? Easiest way to check it is by using something like print string. You probably have a problem with layer indexes(ZOrder).

avatar image Faiberglas Jan 09 '16 at 04:03 PM

Yes. I made a simple script that just prints 'Hello' when you click it and it does, I can use the 'Remove All Widgets' node on the level blueprint to make them go away, but of course that removes every widget on the screen. I wonder if remove from parent is broken? (Or I'm just not using them right...)

avatar image Faiberglas Jan 09 '16 at 04:04 PM

Just did another test and it seems to work now when I put in the open level and remove from parent?? That's weird... I'll let you know if something else happens. Thanks for the help

avatar image Echosyp Jan 09 '16 at 02:53 PM

I'm having the exact same problem, did you ever manage to get this fixed?

avatar image Faiberglas Jan 11 '16 at 11:40 PM

I put the remove from parent after doing the things that it has to do, seems to be working now, but it wasn't before. Make sure to compile your scripts each time you change something before trying it in the viewer...

avatar image Darvos Jan 10 '16 at 05:37 AM

Try putting the remove from parent after opening the level. That's what I did.

avatar image Faiberglas Jan 11 '16 at 11:40 PM

Yeah, that seems to work. Maybe also compiling the scripts before running it?

avatar image SimonRail Jan 11 '16 at 02:57 AM

im in the same situation of LucasKFilms but i tried to put open level before remove from parent... didint work.

I started from the puzzle template in mobile mod

avatar image Faiberglas Jan 11 '16 at 11:41 PM

I put the remove from parent after doing the things that it has to do, seems to be working now, but it wasn't before. Make sure to compile your scripts each time you change something before trying it in the viewer...

avatar image Darvos Jan 11 '16 at 06:39 AM

Try putting this on the level blueprint. alt text

blueprint.png (143.3 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello,

I had the same problem for a while, but when I made the menu smaller, I saw the level was already open. I only followed the UE4 documentation.

The problem: I hit 'Play', the level opens, and in the 'Level Blueprint', the 'Event BeginPlay' creates the menu widget. On the menu, I hit Play, the 'Open level' starts the level again, which creates the menu again.

Solution: Make another level only for the menu, which opens the original playing level.

Easier solution: Don't use 'Open level'.

I'm sure others know better solutions, but if someone else has this problem too and can't find any answer, maybe my solution helps...

more ▼

answered Feb 23 '16 at 07:31 PM

avatar image

Fornesh
26 1 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I put the remove from parent after doing the things that it has to do, seems to be working now, but it wasn't before. Make sure to compile your scripts each time you change something before trying it in the viewer...

more ▼

answered Jan 11 '16 at 11:41 PM

avatar image

Faiberglas
6 1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question