x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Texture value problem

Hi Unreal Experts

I am pretty new to Unreal and I am having the below problem shown on the image.

My problem is that my texture looks extremely different in the unreal viewport even when its unlit compared to how the texture looks in the Unreal texture viewer. What am I doing wrong? Or what is it I do not understand? Why do the texture look soo different in Unlit mode or in general in the viewport?

Please please please help me understand what the problem is or why this is? Is there something you experts do to work around this problem?

alt text

Product Version: UE 4.10
Tags:
more ▼

asked Jan 07 '16 at 11:39 AM in Using UE4

avatar image

JayCee
11 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

The preview has a basic point light and doesn't account for any other things you have set in the world like post processing effects or reflection captures. Unlit removes all lighting effects from the scene and shows only base parameters of color information. Looking over the documentation is very important to understanding how light works in the engine to then understand materials. https://docs.unrealengine.com/latest/INT/Engine/Rendering/LightingAndShadows/index.html

more ▼

answered Jan 07 '16 at 01:29 PM

avatar image

EyeDee10Tee
2.1k 59 14 126

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I think I have solved the problem. I found out that materials in the unlit viewport is shown with specular value of 0.5 This makes the textures look washed out if you do not yet have any specular maps on them. Setting the spec value to 0 makes the unlit texture look the same as in the texture viewer.

If you want to see the the real unlit view, I think you need to use Buffer visualisation base color.

more ▼

answered Jan 07 '16 at 03:47 PM

avatar image

JayCee
11 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question