Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Navmesh generating too far from objects... how can I get my nav mesh to provide pathing through tighter spaces?

Hey there,

I am working on a turn based tactics game. I had my own pathfinding implementation using a*, but I am thinking I will switch to unreals built-in pathfinding.

A unit on my grid is 100x100 unreal units in size. However, if I have a single square that is open, surrounded by walls (i.e. a door), the navmesh doesn't find the doorway as a valid point and it is not used in pathfinding calculations.

Does anyone know of anyway to tighten the nav volume to fit through these spaces or any way (other than using nav link proxies) to get the mesh to work?

here are two examples: alt text alt text

Product Version: UE 4.10
navhelp1.png (423.8 kB)
navhelp2.png (424.3 kB)
more ▼

asked Jan 08 '16 at 06:41 PM in Using UE4

avatar image

18 3 4 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi danforstinger,

Take a look at the RecastNavMesh's Details. The Agent Radius adjusts how close the nav mesh sits to a mesh that alters the nav mesh. Lower this number and you should see that space become walkable. Note that if the collision for the actor attempting to navigate through that space is too big, it still won't make it.

Hope that helps!

more ▼

answered Jan 08 '16 at 07:01 PM

avatar image Dryfter May 21 '17 at 11:32 PM

Hello. Wondering if there are other solutions? Tried this approach, even dialed the Agent Radius value all the way down to zero and I still have gaps - though they are a little closer now...

avatar image HeffU Jul 01 '17 at 10:53 PM

A bit of a late response here, but for anyone stuck with this:

Lowering the Cell Size will let you have better resolution at a higher cost, and should solve the above issue if you have already lowered the Agent Radius.

If you've lowered the Agent Radius and Cell Size with no effect, make sure that you go to your project settings and add a Supported Agent under Navigation System -> Agents, and then set it's Agent Radius there.

It seems that if you do not have any Supported Agent set, it will always reset the Agent Radius to a default value, no matter what you have set in other places.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question