x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Access violation D3D11CreateDevice

Hello,

I uninstalled visual studio 2013 pro, and installed 2015 community.

Then I uninstalled UE4 4.9 and installed 4.10 from the marketplace.

When I tried to launch the engine it crashes immediately.

I uninstalled 4.10 from the marketplace and downloaded the source code and compiled it with no error, and also it crashes as soon as I run it: "Fatal Error! UE4 Editor will now close".

I launched the engine from visual studio and it led me to an exception as shown in the attached image.

4.11 preview 1 has the same issue, and 4.9 is not working anymore.

I have a laptop with 24GB RAM, quad core i7, and a GTX 860m.

There is no project, I am just trying to open the engine, I am not even getting to the create project window.

I reinstalled 2013 professional side by side to community 2015, the issue still persists

I also updated my Nvidia driver (clean install), and installed windows 8.1 SDK but nothing have worked so far.

I was able to run it when if select run with Intel HD graphics. But, If run with nvidia gpu, I get Access violation executing D3D11CreateDevice.

I attached the DXDIAG.txt file. link text

Any ideas?

Product Version: UE 4.10
Tags:
capture.jpg (193.9 kB)
dxdiag.txt (95.2 kB)
more ▼

asked Jan 09 '16 at 06:30 PM in Installation & Setup

avatar image

Night Watcher
1.7k 44 12 71

avatar image Doug E ♦♦ STAFF Jan 11 '16 at 07:34 PM

Hey Night Watcher-

Do you have the 4.11 preview through the Launcher installed? If so you will need to uninstall the prerequisites and then install 4.10. Can you also post the full error message when trying to open the editor? Are you able to install/run 4.9 or does the same issue occur?

Cheers

Doug Wilson

avatar image Night Watcher Jan 11 '16 at 10:55 PM

Well, the error message did not give any information at, it crashes at 0% of the loading, it is hard for me to provide a screenshot now, but it gave no information about the error. The issue from the code is that it was not able to identify the GPU. If I run UE4 using the integrated intel GPU, the engines runs fine. I was able to make the engine run by disabling my integrated GPU, and only then the engine was able to recognize the nvidia gpu. It is a temporarily fix, and I cannot keep using just the dedicated GPU, it kills my battery life. I uninstalled multiple engine version and installed new one, and they did not work, not 4.10.2 not 4.11 and not 4.9, even though 4.9 used to work. Only 4.10 was installed from both the marketplace and github, all other where installed using the marketplace. I updated all my drivers, performed clean installation nothing worked. My guess is that something on my computer made the detect GPU function not work properly, which is the first thing the engine try to run when it starts

avatar image Doug E ♦♦ STAFF Jan 12 '16 at 03:04 PM

Hey Night Watcher-

Are you using a GPU switching software such as Nvidia Optimus? If not I would recommend getting this as it will handle switching between graphics cards seamlessly based on the software applications running.

http://www.nvidia.com/object/optimus_technology.html

Cheers

Doug Wilson

avatar image Night Watcher Jan 14 '16 at 01:35 PM

yes I am using the Nvidia Optimus, and use to work fine, I've been using UE4 since version 1

avatar image Doug E ♦♦ STAFF Jan 15 '16 at 06:14 PM

Can you tell me if the drivers for both cards are up to date? Intel integrated cards have been known to cause freezes/crashes when not using the correct driver. There is more information here:

https://wiki.unrealengine.com/Software_Conflicts

Please try to manually update the Intel drivers manually as described in the link and let me know if you still get the same error when launching the editor.

avatar image Night Watcher Jan 16 '16 at 02:57 AM

I went to the intel website and downloaded the latest driver fro windows 8.1 for my 4600 HD graphics, and it did not work. Also, why this question has been marked as resolved, when it's not?

avatar image Matt.Williams Jan 19 '16 at 07:35 PM

Hi NightWatcher,

It was marked resolved because you used the "Answer" section for your comment and when Staff comments on an Answer, it auto-resolves. I've converted it to a comment to avoid further confusion.

Anyways, can you send me either a screenshot or text copy of the error you are receiving? Is there anything else to the error than "Access violation executing D3D11CreateDevice"?

-Matt W.

EDIT: Also, what is your Nvidia Driver version (it does not say in dxdiag as the current GPU when it was captured was the Integrated Graphics)? If it is 361.43, could you revert to 359.06?

avatar image Night Watcher Jan 21 '16 at 03:18 AM

I'm really sorry, but I am currently overloaded with work, and cannot modify my drivers now, I will send you the requested information in a few days

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Night Watcher,

We haven't heard back from you in a bit, so I'm resolving this post for tracking purposes. When you get a chance to follow Matt's recommendations, let us know what happens if you're still experiencing this problem and we'll continue assisting. Thanks!

more ▼

answered Jan 26 '16 at 06:28 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question