x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Root Motion Z-Axis Problem/Bug

Hello, I have a problem with using root motion. Maybe I'm missing a point, maybe it's a bug, I don't know. Root motion option does not apply on z-axis in both animation editor and in-game. To be more clear and specific let me explain with 2 examples, I got a walking and a climbing animations. Walking animation works perfect because it only interests x-y axis.

At first frame: alt text

After some frames: alt text

As you can see, it's in the same place as it should be and expected. I've already applied this walking anim to my locomotion anim blueprint, works perfectly.

But for climbing animation: At first frame: alt text

At last frame: alt text

Animation location changed in spite of I turned root motion on. I've searched the form and answerhub, most of the people faced with z-axis - root motion problems, but they solved their problem by setting their character's movement mode to flying, I already tried it and didn't work for me. Also in my opinion, this problem is unrelevant with movement component.

If you want to get animations to test them, I'm using mixamo animations, as you know they're free for now, you can download same animations.

Thanks for your help, I hope I'm missing some point and it's not a bug, otherwise we're gonna lose significant time in our job.

Product Version: UE 4.10
Tags:
3.png (535.7 kB)
4.png (538.2 kB)
1.png (510.6 kB)
2.png (522.6 kB)
more ▼

asked Jan 09 '16 at 09:11 PM in Using UE4

avatar image

burak.io
34 5 9 15

avatar image baskiki Feb 15 '16 at 10:23 PM

I have a same problem, how can we fix this ?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I think I found the problem, that would help anyone who uses Mixamo animation that related with z-axis. Climbing animation does not change root bone's location but pelvis. That's why enabling root motion does not effect z-axis.

more ▼

answered Jan 10 '16 at 09:39 AM

avatar image

burak.io
34 5 9 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question