x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Upgrade 4.7.6 -> 4.10.1 Material stopped working on a specific mesh

I'm having a strange issue with a material that stopped working only on a specific mesh after a recent upgrade. If I look at the material in the material editor it draws fine. If I put it on another mesh it draws fine. Of course the mesh it was originally on no longer displays (I just get the default grey checker material)

The material is a somewhat complex water shader that uses displacement and shader functions.

Anyone got any ideas what might have caused this or how I could debug it?

Thanks,

ook

Product Version: UE 4.10
Tags:
more ▼

asked Jan 09 '16 at 10:52 PM in Rendering

avatar image

00k_
219 11 20 30

avatar image Logan Bailey ♦♦ STAFF Jan 10 '16 at 06:51 PM

Hello ook,

Would you please provide a screenshot of your material along with a screenshot of the working and non working mesh?

-Logan

avatar image 00k_ Jan 12 '16 at 12:49 AM

Here's the info you requested. Is it possible that limitations were added for very large meshes?

alt text alt text alt text

meshes.jpg (148.0 kB)
materialmain.jpg (361.9 kB)
avatar image 00k_ Jan 12 '16 at 01:18 AM

After noting the very large mesh size I tried some tests with different poly counts and lowering the poly count seems to have fixed it. I'm still left with needing that mesh to be really big but I can always break it into a number of sections if that's a new engine limitation.

avatar image Logan Bailey ♦♦ STAFF Jan 13 '16 at 02:13 PM

They are in the main folder where you have your project saved. Navigate to the folder that holds your project and it will be within the first folder you open.

Unreal Projects > > Intermediate, Saved, Derived Data Cache

-Logan

avatar image 00k_ Jan 15 '16 at 09:19 PM

When you say "Intermediate, Saved, Derived Data Cache" Do you mean delete the folders with these names inside my project folder? Sory for being so nitpicky but creating and restoring backups is time consuming and tricky given my source control solution.

I don't appear to have anything called Derived Data Cache.

avatar image Logan Bailey ♦♦ STAFF Jan 18 '16 at 03:53 PM

Yes, your project folder where you have your project saved on your computer. Not the folders inside of the project itself. You should be able to copy and past the project folder to create a test for this.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Interesting. There could have been an issue when updating from 4.7 to 4.10.

Make a copy of your Project before trying this

You can try and delete your Intermediate, Saved, and Derived data cache directories form the your project. This will force your project to rebuild when you open it next. If it is still occurring after this would your provide a text project with this material and it not working on a high count polygon mesh.

Thank you,

Logan

more ▼

answered Jan 12 '16 at 02:47 PM

avatar image 00k_ Jan 13 '16 at 12:44 AM

Can you show me the locations of the files / directories I need to delete? I'm not sure where they are exactly.

avatar image 00k_ Jan 24 '16 at 05:59 PM

Deleting my "Intermediate" and "Saved" directories did fix this. I didn't have a "Derived Data Cache" folder.

Can you explain what was at work here? Just would like to better understand it in case I run into future issues.

Thanks again!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question