x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

rmdir ../../../Engine/Config/Redist on game startup

My game was rejected from the Mac App Store for trying to get read/write access to directories that aren't permitted. I have investigated it thoroughly and found that when I start my game it tries to remove these folders "../../../Engine/Config/Redist" 50 times, and then it tries to remove "../../../GameName/Intermediate/Shaders/tmp" and "../../../GameName/Intermediate/Shaders/WorkingDirectory".

My game started with the Third Person template, so then I created a Third Person Template project with no changes and built a Mac app from it. I ran the same tests on it and it also tried to delete "../../../Engine/Config/Redist" but only 3 times.

What is causing this? I need to stop my projects from attempting to delete directories outside of the app, or Apple will not accept it.

I used Xcode, Developer Tools, Instruments, and then chose File Activity and my app. In the Directory I/O tab, it showed the access to the folders happening. I will attach a screenshot of it.

One more thing, I just tested it with the FPS Template, and it does it too. I thought that it didn't do it.

alt text

Product Version: UE 4.9
Tags:
more ▼

asked Jan 11 '16 at 01:22 AM in Bug Reports

avatar image

SKH Apps
28 2 7

avatar image Samantha Sutton ♦♦ STAFF Jan 19 '16 at 09:07 PM

Hey SKH Apps,

Thank you for bringing this to our attention. Is this occurring with each project that you've attempted or has it only been this one project you've tested? Did you create your project in Source or Binary, and which version were you on 4.9, 4.9.1 or 4.9.2? (please include the changelist as well). Have you been able to replicate this in 4.10.2?

Looking forward to hearing back from you, thanks!

avatar image SKH Apps Jan 19 '16 at 10:35 PM

Hello Samantha,

Thank you for responding. :)

The project is from Binary. It happens in all 4.9 and 4.10 including 4.10.2. (It is also in the source version as well.)

I have downloaded the source and searched through it. With the help of two others on the forums (romfeo and fxtentacle) we located the two areas in the source that causes the problems.

In this file: Engine/Source/Runtime/Core/Private/Misc/ConfigCacheIni.cpp

These two lines need to be removed or commented out in order to stop the "../../../Engine/Config/Redist" deletions.

IFileManager::Get().Delete(*FString::Printf(TEXT("%sNoRedist/Base%s.ini"), EngineConfigDir, InBaseIniName), false, true, true); IFileManager::Get().DeleteDirectory(*FString::Printf(TEXT("%sNoRedist"), EngineConfigDir), false, false);

Then in: Engine/Source/Runtime/Core/Private/Misc/Paths.cpp

This line: return FPaths::GameDir() + TEXT("Intermediate/");

needs to be changed to this: return GameUserDir() + TEXT("Intermediate/");

Those lines of code don’t really hurt the game, but Apple's rules don’t allow writing to or deleting directories outside of the sandbox. So the code must be changed to get a game approved for the Mac App Store.

I already recompiled the engine and I am trying to get approved for the Mac App Store again. Hopefully they accept it this time around.

Thanks, Shawn

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Shawn,

Thank you so much for giving so much information and a probable solution to this issue. I have submitted this information in a Jira report to our Developers. UE-25742 is what you'll reference if you'd like to check on this bug.

Thanks again!

more ▼

answered Jan 20 '16 at 03:51 PM

avatar image SKH Apps Jan 20 '16 at 04:35 PM

You are welcome. I couldn't have found it all without Romfeo and Fxtentacle's help. Here's the post about packaging, submitting and getting approved on the Mac App Store to help others: https://forums.unrealengine.com/showthread.php?96569-How-to-create-the-proper-pkg-file-for-deployment-to-the-MacStore

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question