x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Graph is linked to object(s) in external map, cannot play in standalone game

I can't run my game in standalone mode because I get this error

Can't save C:/Users/Byorun/Documents/Unreal Projects/Kaori/Content/Characters/UnitBase/Blueprints/BP_KaoriUnit_Base.uasset: Graph is linked to object(s) in external map. External Object(s): /Engine/Transient Try to find the chain of references to that object (may take some time)?

every time it tries to save this blueprint. The strange thing is that if I try to run it in editor it works without problems. Since this is the 3rd time that this has happened I tried to recreate this blueprint from scratch, resulting in the same error. I can't figure out what exactly is causing the problem.

Product Version: Not Selected
Tags:
more ▼

asked Apr 27 '14 at 06:49 PM in Bug Reports

avatar image

Byorun
133 13 18 22

avatar image Adam Davis STAFF Apr 27 '14 at 07:22 PM

Hi Byorun,

Have you been able to recreate this in a blank project with no additional content? Thank you!

avatar image Byorun Apr 27 '14 at 08:07 PM

until now I was unable to recreate this in a black project. But each time I open this blueprint it breaks more and more alt text

Reparenting to actor and back to character helps with this but it won't fix the external reference. After that I am able to at least use PIE

I noticed that my log has line like this

LogActorComponent: UnregisterComponent: (/Engine/Transient.FloatingPawnMovement_4) Not registered. Aborting.

in it and that is my only hint to a reference to /Engine/Transient

broken_bp.png (332.5 kB)
avatar image Adam Davis STAFF Apr 27 '14 at 08:15 PM

Hi Byorun,

Could you please provide images of the graph for us to reference. This will allow us to see a bit more about what may be going on. Thank you!

avatar image Byorun Apr 27 '14 at 08:37 PM

Here are screenshots from all functions (without interfaces) alt text

alt text

s1.png (400.4 kB)
s2.png (347.0 kB)
avatar image Byorun Apr 27 '14 at 08:39 PM

alt text

That is all there is in this BP. At first I thought that the skeletonmesh was damaged so i re-parent to defaultPawn -> same problem. Maybe the custom enums are causing the problem. After I deleted the Team variable I was (once) able to package my current game to windows (play standalone from the editor still crashed). I readded the variable and reconnected all nodes and the build failed again. So I deleted the variable again but this time the build failed too.

s3.png (108.4 kB)
avatar image Byorun Apr 27 '14 at 08:49 PM

link text

Here is the cooking log if that helps

cook.txt (68.8 kB)
avatar image Byorun Apr 28 '14 at 04:12 PM

Ok I found the cause of the error but still don't know why it is causing the error.

In order to get a working BP again I had to:

  1. Reparent my BP (character -> actor -> character)

  2. Delete the Team variable (custom enum)

  3. cooking -> ok

If I now readd the team variable without connecting it to anything the cooking still works. If I then add the "set Team" as seen in s3.png and connect the team variable to the none slot seen in s2.png the cooking fails.

Now the question what is wrong with this enum ? alt text

enum.png (36.5 kB)
avatar image Adam Davis STAFF Apr 28 '14 at 07:03 PM

Hi Byorun,

Is your project entirely in Blueprints or have you provided any C++ code to it as well? Thank you!

avatar image Byorun Apr 28 '14 at 07:05 PM

It is a BP only project (as long as I can achieve my goal)

avatar image Gareth.Morris.Sumo Jun 03 '14 at 01:54 PM

I had a problem similar to this. I found that I was unable to save out my blueprint and received a similar error. I was creating a derived UObject in a C++ class. Such objects are destroyed by the garbage collector which tracks them via the UPROPERTY() tag. I ended up with something similar to this in the class storing a UMyUObject pointer:

 private:
 UPROPERTY()
 UMyUObject* MyObject;

Unfortunately, the problem arises when you have an empty UPROPERTY declaration which is private. When you attempt to save out the map, you'll find that it throws a wobbler when attempting to reference any private properties not marked transient. You won't have to have changed the asset for this to happen - just the scope of the variable in the C++ class.

The solution in my case was to mark the property as transient.

 private:
 UPROPERTY(transient)
 UMyUObject* MyObject;

One extra thing... When the warning dialog appears, it actually displays a list of privately referenced objects. Engine/Transient is just another private object that is used internally. Engine/Transient won't cause you a problem on its own. You only see it if your own property is broken.

Don't know if that's relevant or related to your problem, but I found this topic whilst searching for a solution to mine and someone else might too.

avatar image Devfo Studios Jan 20 '15 at 02:03 AM

I have been having this bug for multiple weeks now. Every time I a create a project and start doing stuff in it, the error will eventually pop up the next day or so. No solutions from the web have helped at all. Please fix this, Epic. It renders the Engine as unusable for many people, including me.

avatar image Adam Davis STAFF Jan 20 '15 at 07:05 PM

Hi Devfo Studios,

Are you using any level streaming/world browser content in your levels? If so, are these being referenced by your blueprints/level blueprint?

avatar image Devfo Studios Jan 20 '15 at 07:31 PM

No, I'm not using any level stream or world browser content in my game.

avatar image Adam Davis STAFF Jan 20 '15 at 07:47 PM

Does this occur to a specific blueprint or can you reproduce it in a blank project with no additional content? Additionally, what version of the editor are you currently using?

avatar image Devfo Studios Jan 20 '15 at 08:02 PM

Yes, it seems to always be stuck inside a blueprint. I'm using UE 4.6.1

avatar image Adam Davis STAFF Jan 21 '15 at 05:09 PM

Do you have any circular dependencies in your script? For instance, do you have any blueprints that cast to another blueprint, and then eventually (may be multiple blueprints interacting in the function) within the same function chain reference the first blueprint or any blueprint within the chain again? If so remove the circular dependency and see if this fixes the error.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hi Byorun,

Have you been experiencing this since the latest patch went through? Please let us know if you are still experiencing this bug. Thank you!

more ▼

answered May 23 '14 at 07:14 PM

avatar image Byorun May 24 '14 at 06:43 AM

I don't use/have blueprints in my project at the moment. Because of this bug I decided to rebuild my foundation in C++ and try BPs again later.

avatar image WCode Dec 26 '14 at 04:59 AM

I have this bug 4.6.0 - 4.6.1

avatar image Adam Davis STAFF Dec 26 '14 at 02:28 PM

Hi WCode,

Does this occur in a blank project with no additional content? What steps have you taken that reproduce this effect?

avatar image WCode Dec 29 '14 at 12:40 AM

I have a diferent bug thread on answer hub, but its not exacely the same thing and it was do to bad refrences in the Blueprint/ WIdget.

(comments are locked)
10|2000 characters needed characters left

I had a similar issue and I was trying to Load some settings from a saved file in the Constructor part of the Blueprints. After I moved it to the Graph part it all worked fine.

more ▼

answered Apr 27 '14 at 07:47 PM

avatar image

BechD
31 2 3 5

avatar image Byorun Apr 27 '14 at 07:56 PM

In my first defect BP I tried to add a dynamic material to the skeleton mesh in the construction script. In my current try the construction script is empty.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question