x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Media workframe doesn't work on packaged executable on different pc

Hi all, I've come across a problem which I just have no idea how to solve.

I sent packaged executable to client and he is not able to see or hear the video clip which I've setup in UMG. The file I used was .wmv and .wav for audio and synced it in blueprints.

The executable runs the video just fine on my pc. However on his end it doesn't work. Just blackscreen. We are both running it on windows 7.

Any ideas?

Product Version: UE 4.9
Tags:
more ▼

asked Jan 12 '16 at 10:06 PM in Packaging & Deployment

avatar image

Robbie222
176 6 52 19

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello Robbie222,

So in short, the Media Framework is still in experimental stages. I have answered similar questions like this before and it is going to come down to the type of video file you are using. Take a look at the link I have provided below to get some more information on the compatibility limitations of the Media Framework.

Media Framework

https://answers.unrealengine.com/questions/195843/new-media-player-bugs-in-release-473-need-help-asa.html

We are still working on improving this feature, but resources are currently dedicated elsewhere so there is no definite timeframe on the fix. Let me know if you have any further questions.

Cheers,

Andrew Hurley

more ▼

answered Feb 01 '16 at 05:53 PM

avatar image Robbie222 Feb 01 '16 at 06:08 PM

I fixed the problem of not showing up on another pc by simply changing the link of the media asset from absolute to relative. ( By resetting the file location and choosing it again). After repackage again and it works.

However there are still issues when trying to play the video on Mac.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question