x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why won't a set actor location work with a pawn?

Hello,

With the below graph I have taken a screenshot with debug running, what I want to achieve is that the Pawn (Camera) will move in the X world coordinate as the user holds down "W" / "S". I specifically am not using "Add Movement Input" as I am using "Pawn" which I figured out there is no "MovementComponent" unless I'm using "DefaultPawn". I'm not using "DefaultPawn" and as such need to do the movement manually. However after all that work switching over to this I still can't get the camera/pawn to move. The world location of the actor just wont budge and according the graph below it should work.

Any idea's?

alt text

Product Version: Not Selected
Tags:
debuggraph.png (151.4 kB)
more ▼

asked Apr 27 '14 at 09:59 PM in Blueprint Scripting

avatar image

brettclutch
118 13 12 14

avatar image brettclutch Apr 27 '14 at 10:17 PM

What I can find is set to "movable" and my components of my Pawn class is just a static mesh sphere ball and a camera. Of which I have the static mesh set to "movable". There is no other components in my Pawn blue print.

avatar image Shadowriver Apr 27 '14 at 11:43 PM

Other reason why it does not move is blocked target destination

avatar image brettclutch Apr 28 '14 at 04:26 PM

I get a return value of "true" on each SetActor call. Would this still return true if destination is blocked? I'm pretty sure destination area is not blocked.

avatar image Shadowriver Apr 28 '14 at 04:58 PM

It meas move been sucessful

avatar image DizzyWes ♦♦ STAFF Apr 28 '14 at 06:09 PM

Howdy!

Are you doing this inside a pawn blueprint? Is this pawn intended to be a supplemental actor in addition to a player character, or is the pawn the player character? Just trying to get a feel for what you are after and would might be an approach to take.

avatar image brettclutch Apr 28 '14 at 06:11 PM

Thanks, yes this is inside the pawn blueprint. I'm building this as an RTS style camera where there is no character and its just a flying invisible camera. I added code to the pawn blueprint as thats what I saw in the flying blueprint sample. I'm still a little confused as to if my input code should be in the Player Controller or the Pawn still but I believed that Pawn was the right location.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I found the problem, problem was that I have "Camera" as the [ROOT] component of my blueprint components. After I made the component some StaticMesh it started working. Is that expected I wonder?

more ▼

answered May 04 '14 at 03:40 PM

avatar image

brettclutch
118 13 12 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question