x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blueprint compile crash (FastReferenceCollector)

Hi, when i try to compile my blueprint or any of its children i get a "hard" crash without any report crash window so i tried it in visual studio debugging mode. (I got no idea why this crash just suddenly appears) I get the following assertion and call stack.

 At line 265 in "FastReferenceCollector.h" 
 FGCReferenceInfo ReferenceInfo = TokenStream->AccessReferenceInfo(ReferenceTokenStreamIndex);
 
 
 
 Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:D:\BuildFarm\buildmachine_++UE4+Release-4.11\Engine\Source\Runtime\Core\Public\Containers\Array.h] [Line: 785] 
 Array index out of bounds: 0 from an array of size 0
 UE4Editor.exe has triggered a breakpoint.
 
 Call Stack:
 
 >    UE4Editor-CoreUObject.dll!TFastReferenceCollector<FGCReferenceProcessor,FGCCollector,FGCArrayPool>::ProcessObjectArray(TArray<UObject *,FDefaultAllocator> & InObjectsToSerializeArray, TRefCountPtr<FGraphEvent> & MyCompletionGraphEvent) Line 265    C++
      UE4Editor-CoreUObject.dll!TGraphTask<TFastReferenceCollector<FGCReferenceProcessor,FGCCollector,FGCArrayPool>::FCollectorTask>::ExecuteTask(TArray<FBaseGraphTask *,FDefaultAllocator> & NewTasks, ENamedThreads::Type CurrentThread) Line 886    C++
      UE4Editor-Core.dll!FTaskThreadAnyThread::ProcessTasks() Line 1088    C++
      UE4Editor-Core.dll!FTaskThreadAnyThread::ProcessTasksUntilQuit(int QueueIndex) Line 982    C++
      UE4Editor-Core.dll!FTaskThreadBase::Run() Line 469    C++
      UE4Editor-Core.dll!FRunnableThreadWin::Run() Line 74    C++
      UE4Editor-Core.dll!FRunnableThreadWin::GuardedRun() Line 23    C++
      [External Code]    
 
Product Version: UE 4.11 Preview
Tags:
more ▼

asked Jan 13 '16 at 05:42 PM in Bug Reports

avatar image

Eqric
89 19 26 31

avatar image Doug E ♦♦ STAFF Jan 13 '16 at 06:51 PM

Hey Eqric-

Are you creating an array inside your blueprint or the class the blueprint is based on? If so are you able to compile by removing the array? Does the crash occur when compiling a specific blueprint or does it crash when compiling any blueprint? If you are still having compile crashes, can you please provide a copy of your project for me to test directly? If you're able to upload the project somewhere, you can send me a PM on the forums to download it.

Cheers

Doug Wilson

avatar image Eqric Jan 13 '16 at 07:30 PM

There is no arrays inside the blueprint, it contains almost nothing just a few variables ( widget reference, floats). Its just a base blueprint which the children overrides functions from. Seems like only that blueprint is causing the crash.

Just now when i tried to strip the project from all marketplace models i could suddenly compile the blueprint. The blueprint is a parent of several other blueprints which overrides a function inside the function which crashes. One of these children do contain an array itteration. Can it have something to do with it? Not sure what the rules are to send projects which contains market items from Unreal 4 store.

avatar image Doug E ♦♦ STAFF Jan 13 '16 at 07:58 PM

If you're able to upload the project to dropbox you can send me a private message on the forums with a download link for the project. Doing this, you can send the project as it is

avatar image Eqric Jan 13 '16 at 08:16 PM

Private message sent

avatar image Doug E ♦♦ STAFF Jan 13 '16 at 10:04 PM

How does the Item blueprint relate to the IItem interface? I found that compiling the IItem interface first allows the Item blueprint to be compiled without crashing. It's likely that the Item blueprint is corrupt in some way, it should be possible to recreate the blueprint. So far I've not been able to recreate it, I can't seem to get the "Event Request Item Info" node that is in the blueprint.

avatar image Eqric Jan 13 '16 at 10:22 PM

It does't do anything no more, just some leftovers i think. It is just some prototyping so its a mess. Still crashes for me even if i compile IItem first. Btw, can you add a new variable in the structure InventoryItems? I always get a crash when i do that.

Forgot to add that this compiling crash came with preview 2, it worked fine in preview 1.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Eqric,

I may have found the primary source of the crashes you are experiencing. I believe it is linked to your InventoryinHUD interface. Try compiling this first and then compiling your other blueprints, see if you get the same crash. Do you have any circular references that are using this interface?

more ▼

answered Jan 14 '16 at 06:18 PM

avatar image Eqric Jan 14 '16 at 07:47 PM

Thanks a lot for your time, that did actually fix it! Hmm i need to recheck if i got any circular references.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question