x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

I want use openssl library on UE4 project

I'm making sample for using openssl library for my game. I did add staticlibrary for Unrealengine.

(specifically,

  1. myproject > build settings > search paths > always search user paths : yes

  2. myproject > build settings > search paths > library search paths : /usr/local/Cellar/openssl/1.0.2e_1/lib added

  3. myproject > build settings > search paths > user header search paths : /usr/local/Cellar/openssl/1.0.2e_1/include added

  4. Add libcrypto.a, libssl.a to Frameworks

  5. I added codes like below at MyProject.Build.cs. PublicIncludePaths.Add("/usr/local/Cellar/openssl/1.0.2e_1/include"); PublicAdditionalLibraries.Add("/usr/local/Cellar/openssl/1.0.2e_1/lib/libcrypto.a"); PublicAdditionalLibraries.Add("/usr/local/Cellar/openssl/1.0.2e_1/lib/libssl.a");

)

but myproject failed to build. error message was "/usr/local/Cellar/openssl/1.0.2e_1/include/openssl/ossl_typ.h:172:22: error: redefinition of 'UI' as different kind of symbol".

Maybe, "UI" conflicted...

When I emitted 1~3 step, it failed because of same error.

Is there anyone else know to solve this problem??

OS version : OS X El capitan(version 10.11.2)

UE version : 4.9 Xcode : Version 7.2 (7C68)

openssl library version : 1.0.2e_1

I didn't use default openssl on mac (/usr/local/bin)

Product Version: UE 4.9
Tags:
more ▼

asked Jan 14 '16 at 07:50 AM in C++ Programming

avatar image

꽝짱임
6 1 2 2

avatar image 꽝짱임 Jan 15 '16 at 02:08 AM

I solved the problem. I copied openssl library and header files into subdirectory of my project and then modifed ossl_typ.h.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question