x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Physics Blend Weight causing jitter

I'm having troubles with using the Physics Blend Weight functionality.

When blending between physics and animation, there is a lot of jitter between the two.


How to reproduce

Open the map PhysicsAnimation in the content examples. Slide the Physics Blend Weight slider to 0.5

What happens

The limbs with physics applied jump around erratically (they have jitter)

What's expected

The limbs should blend between physics and the animation smoothly.


Here's the documentation on the map and subsequent feature I am referring to: https://docs.unrealengine.com/latest/INT/Engine/Animation/PhysicallyDrivenAnimation/index.html

Hope anyone can shed any light on why this might be.

Best,

Minxies

Product Version: UE 4.10
Tags:
more ▼

asked Jan 16 '16 at 11:21 AM in Blueprint Scripting

avatar image

MinxiesDev
285 18 26 41

avatar image MinxiesDev Jan 21 '16 at 11:49 PM

Really hope someone can throw me a bone with this.

I'm really at a loss with it.

avatar image UnexpectedSquirt Apr 20 '18 at 08:09 PM

Same issue. I'm stumped.

avatar image Zexus_ Mar 26 '16 at 10:06 AM

I came here hoping to find an answer to this, did you figure it out yet ?

avatar image hiili May 10 '16 at 11:13 AM

I also stumbled on this on engine & content examples version 4.11 (binary release). It definitely seems like a bug in the blending system. Epic, is someone already looking at this?

The issue becomes even more pronounced by setting the active animation sequence of the characters to "Idle". (Select the character -> select the SkeletalMesh1 component -> set "Anim to Play" to "Idle")

Initially, the characters stand almost still. Moving the blend weight slider even slightly away from 0.0 immediately introduces a steady "jitter" cycle: all affected bones seem to alter between falling freely and snapping back toward an apparently correctly blended pose. On my computer, this cycle runs at around 2-3 times per second.

avatar image hiili May 10 '16 at 11:24 AM

For others who find this question, the discussion seems to continue here: https://forums.unrealengine.com/showthread.php?73797-Full-ragdoll-blending-stability

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

This issue can be resolved by using the new PhysicsAnim UActorComponent.

You might also want to look at some of the animation solutions in the AnimGraph.

more ▼

answered Apr 20 '18 at 08:35 PM

avatar image

MinxiesDev
285 18 26 41

avatar image UnexpectedSquirt Apr 20 '18 at 09:59 PM

In my case the issue was resolved by turning off 'bEnableUpdateRateOptimizations' on the skeletalmeshcomponent. Apparently this optimization interferes with the physics blending, even when the camera is very close to the mesh.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question