Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE 4.10.2 + VS2015 Update 1 Issue


I'm not sure in which category I should post this issue. I'm using VS 2015 with update 1 and after upgrading from 4.10.1 to 4.10.2, problem has appeared:

When I'm trying to add new C++ class form editor or compile my C++ source from editor, VS crashes(?) with message (see attached image).

I couldn't figure out certain condition why it happens, but it happens very often (almost always). And it never happens when I compile from VS itself.

I tried to google it, but unfortunately couldn't find any solution :/

Thanks in advance!

alt text

Product Version: UE 4.10
errormessage.jpg (136.1 kB)
more ▼

asked Jan 16 '16 at 09:00 PM in Bug Reports

avatar image

124 5 8 63

avatar image Doug E ♦♦ STAFF Jan 18 '16 at 03:04 PM

Hey Airuen-

What code are you changing when you see this message? Are you able to add code to a project that is purely blueprints? Does the compile succeed after restarting VS as the error suggests?


Doug Wilson

avatar image Airuen Jan 19 '16 at 04:50 PM


Its hard to say what exactly I have done. Two times it happened when I just added new C++ class, based on AActor. After VS restart it have compiled just fine. Other times it was standard coding routine - adding/removing properties in my classes, adding methods, etc =)

My project was created in 4.10.1 if it does matter. I have tried to reproduce it in newly created 4.10.2 project, but it not happened. All fine with new project.

How to say. It't not like I'm stuck with it, It was happening from time to time (when I have worked alot with C++ part of my project) and I posted it here because maybe this is some kind of known issue. If you have no Idea what it is, then it maybe unrelated to UE4 and just my system problem.

But If you have any idea what it could be, or what I should check (maybe some logs somewhere?) - I would be glad to hear.


avatar image Doug E ♦♦ STAFF Jan 19 '16 at 06:50 PM

I tried creating a project in 4.10.1 then upgrade to 4.10.2 with VS2015 and Update 1. After doing so I was able to add a new class based on actor to the project which compiled and opened in Visual Studio with no issues. If you're not seeing the same behavior in a new project either, it is possible that it is isolated to the current project. What else can you tell me about the project where this is happening?

avatar image Airuen Jan 20 '16 at 06:04 PM

Nothing special in this project. Created as mobile blueprint project, extended with some C++ classes. Engine version from launcher.

Some windows updates were awaiting PC restart during that time. Could it be the issue?

avatar image Doug E ♦♦ STAFF Jan 26 '16 at 07:37 PM

Hey Airuen-

Are you getting the same error when trying to add code to another project? Are you seeing this error when compiling code in Visual Studio or when using the compile button inside the editor? Were you able to see if installing the Windows updates helped? You may want to try uninstalling/reinstalling Visual Studio as well.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first


After windows update the problem has disappeared. I think pending windows updates was the issue.

more ▼

answered Jan 26 '16 at 11:23 PM

avatar image

124 5 8 63

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Epic specifically said that 4.10.2 is not compatible with VS 2015 update 1.

more ▼

answered Jan 16 '16 at 09:05 PM

avatar image

1.7k 81 28 81

avatar image Airuen Jan 17 '16 at 05:38 AM

It was at start, but on tread you can find:

Stephen Ellis Unreal Engine Developer

"After further investigation, we believe we were incorrect about our warning that VS2015-Update1 does not work with 4.10.2, and that we were being overly cautious. At this time, we expect that the VS update should not have any conflicts with 4.10.2".

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question