x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blender animations to unreal.

So I've made some custom characters in Blender and made several animations for them, I've scaled them all appropriately so that when I import the character meshes into Unreal, that are the correct size I need them to be. The animations, despite being scaled and imported in the exact same way, once applied to the meshes suddenly scales them down to near microscopic size. I'd appreciate an answer because I've tried every suggested solution and nothing seems to work.

Product Version: UE 4.10
Tags:
more ▼

asked Jan 18 '16 at 08:17 AM in Using UE4

avatar image

GothicJack
6 1 1

avatar image daniele_niero Jan 18 '16 at 08:29 AM

I would export one of those animations as Ascii, so to see what exactly is defined in the FBX in term of units and scale.

That could give you a first hint at what the problem might be.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

ASCII fbx files don't work in unreal. Did you scale in object or edit mode? Anytime you scale in object mode you must hit ctrl a and apply scale. I think that's your problem. To clarify for future reference. The cube that shows up in the start scene is one blender unit. If you scale up in object mode it changes the unit size. If you scale in edit mode the scale remains at one unit. That's why it is important to know what mode you scale in. If scaling in object mode ctrl a and apply scale will set it back to one unit as the size you have it as.

more ▼

answered Jan 18 '16 at 09:41 AM

avatar image

EyeDee10Tee
2.1k 59 14 128

avatar image daniele_niero Jan 19 '16 at 09:02 AM

Sorry, what does make you think an ASCII fbx won't work in Unreal? I export my FBXes only in Ascii and I have never had a problem.

Beside this, there might be confusion between what is an unit in Blender (or Maya or XSI or Lightwave or Modo) and what is exported to FBX and again what is red back in Unreal (or any of the software above).

1 is always 1 and when programming there is not meaning of real world measurement such as centimetres, meters, feet etc. That is an extra knowledge that each software decide to handle by themselves and eventually in different ways. For example Maya may decide that 1 written to a file correspond to 1 real life meter, and Lightwave might decide that it is instead 1 real life centimetre (This is an example. I don't recall exactly what the 2 softwares do). Therefore exporting between them, back and forward, could cause all possible scale issues. That's why XSI decided to don't deal with real life measurements and treat everything in simple Units. The user decide what a Unit should be. But what XSI writes when exporting to FBX? 1 unit will be 1 metre or 1 feet?

Now FBX indeed deals with real life measurements and to let any exporter-importer to treat the data properly it can store in wich real life measurment this data should be treated. Exporting in Ascii will make easy to read and know this information and possible find where and who is causing the problem.

I hope it's more clear now.

avatar image C4chaos Jul 09 '16 at 01:55 PM

daniele_niero are you using blender when you say you use ASCII? as blender is under the GPL license and they can not use fbx sdk so when it comes to blender that why blender is so far behind on the fbx. the unit in blender is is odd we have 2 set of units in blender and I am not talking about cm to m or km we have units in object mode then we have edit mode units in object mode you would want every thing on location at 0.0.0 rotation at 0.0.0 and for scale 1.1.1 changing these can cause problems

avatar image daniele_niero Jul 10 '16 at 08:13 AM

Hi,

No, I'm not using blender myself, and I understand that not being an autodesk product it is a little far behind on fbx.
However I don't follow your point.
Fbx sdk can be used by anyone, as far as I know, you don't need a license.
Either way, binary and ascii are supported by any release of fbx.
Now, sdk means just the library to write your own importer/exporter, so if blender doesn't support exporting fbx in ascii format is just because it has not been implemented in their export. Something that you users should ask, if that is the case.
About units, again, it doesn't matter what Blender uses, when exporting to fbx, in the file itself, the scale in relation to the original scale has to be defined. If the file is ascii, you can easily read it.
In this case we are not talking about cm, meters, or whatever, just two double float numbers. ``` P: "UnitScaleFactor", "double", "Number", "",1 P: "OriginalUnitScaleFactor", "double", "Number", "",1 ``` Then you can already find something that can help to debug the issue.

Sorry if I ask, but are you (and the other guys) programmers of any level? Because from your answers and doubts it looks like there is a lot of confusion about what a file format is and especially what the fbx really is (and the same could be said for Alembic or Collada). I don't say this in any negative way, but if I'm correct, then trust me a little bit: I do this for a living ;)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi, i've had the same issue and this worked for me:

  1. Make sure your blender file is set to metric (or imperial if you <3 second amendment)

  2. Make sure both the skeleton and the mesh look to size as if it were a real object

  3. UPscale BOTH the skeleton AND the mesh about 100:1 in OBJECT MODE. In fact, everything happens in OBJECT MODE

  4. APPLY scale with Ctrl+A to BOTH skeleton AND mesh

  5. now DOWNsize both skeleton AND mesh to 1:100

  6. Apply scale to ONLY MESH.

This is probably because when you add a skeleton in Blender, it gets no scale info or something.

I hope this helps because it gave us a terrible pain up the pooper.

more ▼

answered May 10 '16 at 03:59 PM

avatar image

Trent LeBreaux
103 4 6 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Or you can use the scale option in the fbx exporter as mentioned in this video Unreal Engine 4 Support Twitch Broadcast: Blender and UE4

more ▼

answered Sep 05 '16 at 03:50 AM

avatar image

king-worm
60 4 5 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question