x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Multiplayer Shooter disconnects when Server presses Play

When I play in the editor, with 2 players, if I press play on the server first, the client loses its connection without having navigated to the server list or anything. When the client presses play first, I can actually select the server from the server list, but I then get a black screen on the server, except for the score and the revolver ammo hud. The client's screen looks correct with the connected player on the opposite end of the level. The score hud updates on both screens if the client manages to kill the other player.

I'm just confused as to why this behavior exists and what I would need to do to fix this behavior. The project is a blueprint project running on 4.10.2

Product Version: UE 4.10
Tags:
more ▼

asked Jan 19 '16 at 05:15 AM in Blueprint Scripting

avatar image

frobro98
8 1 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

from waht I see on different topic, launching server from PIE is awfull. Lot of bug, and it is not adviced to launch from PIE. Moreover, are you on editor you build from source? Because standard version is not supported dedicated server.

FRom my side I launching server in command line ue4editor myproject mylevel -server -log

more ▼

answered Jan 19 '16 at 05:46 AM

avatar image

thyshimrod
399 22 11 39

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

from waht I see on different topic, launching server from PIE is awfull. Lot of bug, and it is not adviced to launch from PIE. Moreover, are you on editor you build from source? Because standard version is not supported dedicated server.

FRom my side I launching server in command line ue4editor myproject mylevel -server -log

more ▼

answered Jan 19 '16 at 05:47 AM

avatar image

thyshimrod
399 22 11 39

avatar image frobro98 Jan 19 '16 at 05:17 PM

Thanks for the response! I tried the command line and that had it work for me. I don't necessarily know if 2 games running on the same computer would count as a LAN game, but I was wondering if there is a way for it to work without having to launch a server everytime

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question