x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Collision mesh size in editor differs from one in phat

I downloaded some free model and added a skeleton for it in blender. When I imported it to ue4 and made collisions in phat collisions were acting weird. I checked "Show collisions" (alt+c) in editor and it came out that collisions in editors are much smaller than those in phat (first image).

I did some tests in simulation mode hiting forlift with a chair (that sounds stupid) and it seems that collision works correctly (as shown in phat). I guess that it's size is only displayed wrong.

alt text Below You can (barely) see orange collision meshes.They are positioned in right places (on the bones) but are super small. alt text

Product Version: UE 4.10
Tags:
more ▼

asked Jan 19 '16 at 01:41 PM in Bug Reports

avatar image

dzarafata
132 6 16 20

avatar image Matthew J Jan 19 '16 at 03:46 PM

Hello dzarafata,

This isn't something that I've seen previously so I'm not quite sure off the top of my head what could be causing it. Seeing as you mentioned that it was a free asset, would it be possible for you to upload the FBX (skeleton included, if possible) so that I can see if it's the asset itself?

avatar image dzarafata Jan 19 '16 at 04:19 PM

Sure, I included blend file and FBX I've exported:

https://www.dropbox.com/s/bwkmuhrxbryaor0/forkliftBlednerAndFBX.rar?dl=0

I'm using ue4.10.2

avatar image Matthew J Jan 19 '16 at 07:24 PM

Thank you for the report, dzarafata. I've placed a bug in for the issue related to the PHAT bodies being considerably smaller visually in the main editor viewport. For reference, the bug number is UE-25684. While messing with this, I also found another issue with the scaling of the physics bodies in the PHAT editor so I'll be putting that in as well.

avatar image Matthew J Jan 20 '16 at 06:23 PM

I should've checked before entering the bug report but I'm unable to get this same behavior with any other asset that is imported into the engine. This could be an asset specific issue. I'll be taking a look at the blend file you sent to see if I can find out more.

avatar image dzarafata Jan 20 '16 at 06:55 PM

I also don't have problems with another assets. I'm using Blender 2.76 RC. I downloaded this model as .obj that I've imported to blender. Original file is here: https://www.dropbox.com/s/hhqrrv018brixsy/ysjwscia97-REORCForklift.7z?dl=0 Here are export settings that I've used with blender: alt text alt text alt text alt text

avatar image Matthew J Jan 26 '16 at 05:44 PM

We've found out that it is something to do with the settings prior to importing it, namely the scale factor between the root and the individual bones. We're looking into fixing it correctly and I'll get back to you soon.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It seems that it would be best to rig the model again from inside of Blender. The problem was caused by the scale value difference between the Root and the individual bones on the mesh. From looking at the root and bones from inside blender, the scale for all of the bones is set to 100 while the root doesn't have a scale due to how blender does things. When it gets exported and imported (to Maya at least) these values change around. It ends up with the root being 100 and the bones themselves being 1. This ends up with the bones being 1% of the size that they should be in comparison to the root.

When rigging the mesh again, be sure to keep the scale values at 1 across all of the bones and it should end up correct. We tried this locally and it imported into UE4 without any issues.

Hope this helps!

more ▼

answered Jan 28 '16 at 08:35 PM

avatar image user340634534 May 15 '17 at 01:14 PM

Can you clarify please? As i understand in this particular model bone scale was an error, but what if scale is there intentionally? (In my case scale is used further down in blueprint)

  1. Is the difference in collision between phat viewport and level editor expected behavior? In phat viewport i see correctly scaled collisions depending on corresponding bone scale, but if skeletal mesh placed in level all collisions are uniformly scaled.

  2. If not is there a associated bug report to follow the progress of fixing this?

edit: just to clarify, problem i'm having is not with display of collision mesh, is that collision on scaled bone is behaving(and looks also) like there was no scale applied. I've looked at UE-25684 and it is about display only as i understand.

avatar image Matthew J May 18 '17 at 04:05 PM

Due to how old this post is, I would suggest making your own bug report for this if you believe that the exporting/importing from Maya, 3DSMax or Blender, whichever program you're using, is not working correctly with scale. It seems like your issue is similar but not exactly the same thing.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question