x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editor crashes on launch: filename not found [in UE4Editor-Core.dylib]

Cannot start unreal due to crash on Os X (el capitan).

I have tried to uninstall everything and reinstalling it (based on https://answers.unrealengine.com/questions/32845/how-to-uninstall-ue4.html).

Crash report is in attached file. Please ask away if there is any information missing that might help you.

Callstack:

 FGenericPlatformMisc::RaiseException(unsigned int) Address = 0x103de3e1b (filename not found) [in UE4Editor-Core.dylib]
 FOutputDeviceMacError::Serialize(wchar_t const*, ELogVerbosity::Type, FName const&) Address = 0x103f6c317 (filename not found) [in UE4Editor-Core.dylib]
 FOutputDevice::Logf(wchar_t const*, ...) Address = 0x103fe0702 (filename not found) [in UE4Editor-Core.dylib]
 FDebug::AssertFailed(char const*, char const*, int, wchar_t const*, ...) Address = 0x103fc7df4 (filename not found) [in UE4Editor-Core.dylib]
 LoadShaderSourceFileChecked(wchar_t const*, FString&) Address = 0x10a4351e3 (filename not found) [in UE4Editor-ShaderCore.dylib]
 GetShaderIncludes(wchar_t const*, TArray<FString, FDefaultAllocator>&, unsigned int) Address = 0x10a436396 (filename not found) [in UE4Editor-ShaderCore.dylib]
 AddShaderSourceFileEntry(TArray<FString, FDefaultAllocator>&, FString const&) Address = 0x10a43fc30 (filename not found) [in UE4Editor-ShaderCore.dylib]
 GetAllShaderSourceFiles(TArray<FString, FDefaultAllocator>&) Address = 0x10a434d44 (filename not found) [in UE4Editor-ShaderCore.dylib]
 BuildShaderFileToUniformBufferMap(TMap<FString, TArray<wchar_t const*, FDefaultAllocator>, FDefaultSetAllocator, TDefaultMapKeyFuncs<FString, TArray<wchar_t const*, FDefaultAllocator>, false> >&) Address = 0x10a436d5f (filename not found) [in UE4Editor-ShaderCore.dylib]
 InitializeShaderTypes() Address = 0x10a439166 (filename not found) [in UE4Editor-ShaderCore.dylib]
 FEngineLoop::PreInit(wchar_t const*) Address = 0x103d1dde0 (filename not found) [in UE4Editor]
 GuardedMain(wchar_t const*) Address = 0x103d32224 (filename not found) [in UE4Editor]
 -[UE4AppDelegate runGameThread:] Address = 0x103d41e83 (filename not found) [in UE4Editor]
 -[FCocoaGameThread main] Address = 0x103ec79db (filename not found) [in UE4Editor-Core.dylib]
 Unknown() Address = 0x7fff8e04fc6f (filename not found) [in Foundation]
 _pthread_body Address = 0x7fff8f84ac13 (filename not found) [in libsystem_pthread.dylib]
 _pthread_body Address = 0x7fff8f84ab90 (filename not found) [in libsystem_pthread.dylib]
 thread_start Address = 0x7fff8f848375 (filename not found) [in libsystem_pthread.dylib]

link text

Product Version: UE 4.10
Tags:
report.zip (31.3 kB)
more ▼

asked Jan 21 '16 at 03:10 PM in Bug Reports

avatar image

PhroZenOne
154 7 16 22

avatar image Steve Hardister ♦♦ STAFF Jan 21 '16 at 05:48 PM

Hi PhroZenOne,

At what point is the editor crashing? Do you have access to the launcher? If so, select the library tab and at the top of the launcher, click on the drop down menu and select "Verify" for that version of the engine. Also, if the Launcher is working, add an engine and install an earlier version of the engine.

If the launcher itself is not available, please post your systems specs: You can find this in the Apple menu >About This Mac>More Info> Add the information from this window (serial # not necessary).

Also, if the crash reporter pop-up is present when the crash occurs please press the copy callstack to clipboard button, paste that in a text file, and post here. Finally, it is important that you hit "Submit" on the the crash reporter pop-up because vital information sent that way is not obtainable by us without that action.

-Steve H.

avatar image PhroZenOne Jan 22 '16 at 01:44 AM

Hi. It crashes at startup of the editor.

Yes I have access to the launcher and are staring the editor through the launcher.

I have run the verify function without any change.

I installed 4.9.2 and it crashed in the exact same way.

I did submit the crash. Complete stack and extra info from last crash is attached to this comment. Also, the original post had the previous crash files attached (zip format).

link text

error.txt (56.3 kB)
avatar image Rasikananda Jun 21 '18 at 04:32 PM

I have an iMac (Retina 5k, 27-inch, Late 2014), 4 GHz Intel Core i7, 32 GB 1600 MHz DDR3, AMD Radeon R9 M295X 4096 MB.

I've never been able to open the editor. It always crashes on startup with the following error:


link text

My filesystem is not case sensitive.

Any ideas?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I found out the reason for the crash. My file system is case sensitive (not default in OS X). The file could not be found because VHACD.Build.cs referred to the file with wrong case (/lib/ vs /Lib/).

This crash is fixed in 660ab7f0c9d34a5772d9e7dad80e63be54ecae65

Btw, that commit is HUGE (648 290 lines!), why the hell would someone allow commits like that. You can't trace history or even diff it in a reasonable way. Please find the person responsible for stuff like that and pour some cold water over his/her head.

more ▼

answered Jan 30 '16 at 07:39 PM

avatar image

PhroZenOne
154 7 16 22

avatar image Steve Hardister ♦♦ STAFF Jan 26 '16 at 09:50 PM

Thanks for submitting your crash using the Crash Reporter. Using that information I was able link this with other reports in order to file the following bug report: JIRA [UE-26014] This will greatly aid our developers in pinpointing the cause of the crash, at which point an update will be added to this post.

In the meantime, here are some more things you can try:

  • If any USB devices or other peripherals are plugged in, unplug them and try starting the editor.

  • Try deleting your DerivedDataCache folder: (Users>Shared>UnrealEngine>[Engine Version]>Engine>DerivedDataCache) and restarting the editor

  • If present, temporarily remove any projects from Users>[Your Name]>Documents>Unreal Projects (Place in a folder on your desktop) and restart the editor

-Steve H.

avatar image PhroZenOne Jan 30 '16 at 02:32 PM

I have tried your suggestions but without any progress. Please advice if there is anything more you need to know. Currently I will try to build unreal from source instead. I'll come back to you with the results of that endeavour.

avatar image Steve Hardister ♦♦ STAFF Feb 01 '16 at 03:13 PM

Thanks for posting the solution for your crash. In regards to the huge commit, that particular commit is a merge of one of our internal Development branches into the Master branch. Unfortunately the development branches are not yet mirrored to GitHub so the individual commits are not currently visible.

We are currently working on finding the best way to mirror the internal development branches to GitHub.

avatar image tompark Mar 06 '16 at 05:05 AM

I also use a case-sensitive file system on a Mac, and was getting this crash too.

To anyone else having this problem, look for error message in ~/Library/Logs/Unreal\ Engine/Editor/UE4.log

In my case, the error was: Couldn't load shader file 'LpvDirectionalOcclusion', which is located at /Users/Shared/UnrealEngine/[version number]/Engine/Shaders/.

I had to rename LPVDirectionalOcclusion.usfto LpvDirectionalOcclusion.usf (i.e. change the "PV" to lowercase), and that fixed the "filename not found" crash.

avatar image Bamwd5 Jul 06 '16 at 08:58 PM

I am having these same errors and do not have a case-sensitive file system... Any other thoughts on this???

avatar image Steve Hardister ♦♦ STAFF Jul 07 '16 at 05:46 PM

@Bamwd5: In order to help you, we will need the Callstack (like in the initial post) as well as your system specs.

avatar image Bamwd5 Jul 07 '16 at 08:03 PM

Sure, no problem. I have attached the log and it was developed on MacBook Pro (Retina, 15-inch, Mid 2015), 2.5 GHz Intel Core i7, Intel Iris Pro Graphics AMD Radeon R9 M370X with 2GB of GDDR5 memory and automatic graphics switching.

This is the Macbook Air (Macbook air 5,1) that the packaged app crashes on with the attached log. http://www.everymac.com/systems/apple/macbook-air/specs/macbook-air-core-i5-1.7-11-mid-2012-specs.html

The packaged app also crashes on Macbook Pro mid-2011

link text

avatar image Steve Hardister ♦♦ STAFF Jul 08 '16 at 06:24 PM

The packaged app is going to crash on the Macbook Pro mid-2011 because it is running HD Graphics 3000 with open GL 3.3, which is not compatible with UE4. Please send the crash log from the Macbook Air which is running HD Graphics 4000 with Open GL 4.1, which is compatible. Also, does the packaged app run on the Pro Retina 15 inch that it was developed on?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I'd gotten the same problem on Version 4.16.3-3561208+++UE4+Release-4.16. I installed to case sensitive volume on my iMac.

Then I created a optional volume with IGNORE CASE and install UnrealEditor to that.

Finally I got it !! :-)

more ▼

answered Aug 07 '17 at 03:50 PM

avatar image

sugitach
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question