x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

PrerequisiteError R-256

I'm getting prerequisite error R-256 on UE 4.10.2 installation. I have uninstalled the VS 2015 C++ redistributables and still get the error. It is run as admin. Logs are included. Thanks in advance :)

Product Version: UE 4.10
Tags:
logs.zip (276.0 kB)
more ▼

asked Jan 22 '16 at 12:02 AM in Installation & Setup

avatar image

GotoPlanB
1 2 1

avatar image GotoPlanB Jan 22 '16 at 01:25 PM

Update: Ran the prerequisite installer exe this time not from the launcher and now it shows "Launch Unreal Engine 4.10.2" however when I click that (or the UE4 exe directly from the folder) I get this error "The application was unable to start correctly (0xc0000013). Click OK to close the application".

avatar image GotoPlanB Jan 25 '16 at 01:14 PM

Does anyone have any advice on what I can do? If more information is needed I can upload it. I really need this working soon as possible, its for a university project. Thanks.

avatar image ModernRyoga ♦♦ STAFF Jan 27 '16 at 08:22 PM

Hello GotoPlanB,

I'm sorry to hear that you're having trouble. Is this a new install or do you have any other version of the engine installed on your system?

avatar image GotoPlanB Jan 27 '16 at 08:38 PM

I have UDK which I guess is the free version of Unreal Engine 3 installed from a couple of years back, it worked fine.

avatar image ModernRyoga ♦♦ STAFF Jan 28 '16 at 05:21 PM

Hello again,

Could you also attach your DXDiag to this post?

avatar image GotoPlanB Jan 28 '16 at 07:30 PM

Here is the DXDiag file.

dxdiag.txt (53.8 kB)
avatar image GotoPlanB Feb 03 '16 at 02:48 PM

Still really need this fixed, can anyone help me out please?

avatar image ModernRyoga ♦♦ STAFF Feb 05 '16 at 09:17 PM

Hello!

We have recently updated the launcher to address some of the prerequisite issues. Please see the accepted answer to this post for the steps to follow.

If this does not resolve the issue, please post back and keep us updated.

avatar image GotoPlanB Feb 06 '16 at 03:19 PM

Instead of the initial error any time I click launch, run the .exe from the folder (or any other .exe in the folder for that matter) I now get Application error (0xc0000013) and have to close. I completely removed UE4 and all prerequisites and also UDK (don't use that anymore anyways) including the launcher and did a fresh download and install of the launcher and UE4 and also manually installed all of the required prerequisites. I had it running as admin at all points. I no longer thing the prerequisite are the issue here. I do notice a fatal error in the launcher logs that I got "BuildDataGenerator: FATAL ERROR: EBuildPatchInstallError::ApplicationClosing," would this be the issue? I noticed it also showed in the logs before the fresh download/install.

Note - I did change my graphics card and all the drivers yesterday, but I was getting this error before the change (just in case you see the change in the dxdiag or something). I also recently disabled all startup and services in msconfig (Microsoft services were all hidden and not disabled) so could that have an effect? Logs and screenshot of the error are attached.

dxdiag.txt (40.9 kB)
logs.zip (1.8 MB)
ue4.jpg (21.2 kB)
avatar image Adam Davis STAFF Feb 09 '16 at 09:48 PM

Hi GotoPlanB,

It doesn't look as though your hardware is the problem after reading through your dxdiag.

  • What are the exact steps you are taking and how far into launching the editor do you get before the crash occurs?

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?

  • Have you experienced this error in any other launcher version or is it limited to 4.10?

  • If you open your task manager, are you seeing a large spike in CPU usage when you open the editor before the crash occurs?

avatar image GotoPlanB Feb 09 '16 at 10:45 PM

Hi Adam, the launcher works fine, its when I click the "Launch" button I get the error (0xc0000013). Running ANY .exe file from the UE4 files causes this error (apart from the 86x and 64x prerequisite installers). No project can be opened, this is my first time running UE4 and I can't get past the launcher. I have tried the 4.11.0 preview 5 and had the same error (my internet is very slow so downloading and testing other versions is tedious). There is barely any CPU usage change (launcher jumps to 1-2% and the UE4Editor.exe process starts up, however it starts with 0% usage.

avatar image Adam Davis STAFF Feb 10 '16 at 07:28 PM

Have you tried opening a project from the projects .uproject folder? To do so, go to \Unreal Projects\PROJECTNAME\ and double click the .uproject folder. Where are you installing the engine? Have you tried verifying your engine build? to do so, go to launcher>library>engine version context menu>verify. This will check your engine folders to see if any are damaged/missing and repair/replace them.

avatar image GotoPlanB Feb 10 '16 at 09:02 PM

When I try to start a project I get the same error (0xc0000013). I have verified lots of times on both UE4 versions but just ran it again to make sure, still getting the error.

avatar image Adam Davis STAFF Feb 10 '16 at 09:09 PM

Do you have a firewall? If yes, have you made sure that both UE4 and Swarmagent are set as exceptions?

avatar image GotoPlanB Feb 10 '16 at 09:35 PM

No firewall, no antivirus active.

avatar image Adam Davis STAFF Feb 11 '16 at 08:37 PM

Can you try an earlier engine version? Have you tried opening 4.9.2 to see if it may be something in the more recent builds that is causing this error to occur?

avatar image GotoPlanB Feb 12 '16 at 04:48 PM

Well I'll be damned, Adam you're a genius :D 4.9.2 opened up first try without any errors or problems so now we're getting somewhere. It must be something in the latest versions that is causing me trouble then?

avatar image Adam Davis STAFF Feb 12 '16 at 04:53 PM

Try installing visual studio 2015 to see if you get the same error. 4.10 was updated to VS 2015, so if you don't have it or the Redist files it won't run.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi GotoPlanB,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

more ▼

answered Feb 16 '16 at 06:26 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question