x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How To Create A Working Shipping Build?

Hi,

I'm having some serious issues with creating a working shipping build from my UE4 projects. The packaging itself works like a charm but I'm not able to run the resulting EXE files. Here's what I did:

  • I Created a new (Bluperint only) project based on the "Topdown template" and named it "AAA"

  • I opened the project and under "File -> Package Project -> Build Configuration" I checked "Shipping"

  • After that I packacked the project on my desktop via "File -> Package Project -> Windows -> 64 Bit"

  • The packaging succeeded

  • Next I wanted to launch the packaged project on my desktop and at first I tried "Desktop\AAA\WindowsNoEditor\AAA.exe" which resulted in the following error message:"Failed to open descriptor file '../../../AAA-Win64-Shipping.uproject'

alt text

  • After that I tried to open the second exe which is located in the "Binaries\Win64" folder of the packaged project and this gave me the same error

  • The only way that I found to solve this issue was to rename the exe in the "Binaries/Win64" folder to "AAA.exe". But this can't be the right way because the exe in the root folder still does not work...

So can please anybody explain how to resolve this issue?

Thanks and best regards, Daniel

EDIT: I found out that it has something to do with Blueprint only projects. If I create empty a C++ class inside the Blueprint project, the resulting build works perfectly fine... So maybe it's a bug in UE4 that affects BP projects?

Product Version: UE 4.9
Tags:
error_01.png (14.4 kB)
more ▼

asked Jan 22 '16 at 10:53 AM in Packaging & Deployment

avatar image

polygon
71 6 13 23

avatar image Adam Davis STAFF Jan 25 '16 at 05:06 PM

Hi polygon,

Have you tried the steps located here to package your project?

https://docs.unrealengine.com/latest/INT/Engine/Basics/Projects/Packaging/index.html

If so, can you create a blank blueprint project and package to windows, do you see the same error?

avatar image polygon Jan 25 '16 at 07:20 PM

Hi Adam,

yes, I tried all those steps but the result is always the same with 4.9 :( A blank project in 4.9 also leads to the same result. The only thing that works for me is a placeholder C++ class in the project.

The issue does not occur in 4.10 for me and it's quite strange...

avatar image Adam Davis STAFF Jan 26 '16 at 02:49 PM

Try verifying your engine build by going to Launcher>Library>Engine version drop down menu>verify. This will check to ensure that there are no damaged or missing files on your build and repair/replace them if there are.

avatar image polygon Jan 26 '16 at 03:29 PM

This didn't solve the issue :(

avatar image Adam Davis STAFF Jan 26 '16 at 10:17 PM

So, just to confirm, you are able to package in 4.10, but does not work in 4.9? This may be a bug that has already been addressed in later builds.

avatar image polygon Jan 27 '16 at 08:50 AM

Hi Adam,

yes, that's right. Creating shipping builds in 4.9 (no matter which update) does not work in blueprints projects only. It does only work as soon as I add a placeholder C++ class to my project. Even the templates or a completely empty project do not work.

In 4.10 the BP only projects as well as the templates from UE4 work. But I noticed a strange issue here as well: If the desired project contains a plugin, the shipping build does not work and when I start the exe, the same error described above occurs (tested with the plugins "Varest" and "Advanced Sessions")

Best regards, Daniel

avatar image Adam Davis STAFF Jan 27 '16 at 03:19 PM

In your 4.9 project, do you have these plugins active as well? Have you contacted the creators of these plugins? There may be known issues with the specific plugins that are causing the error you are seeing.

avatar image polygon Jan 27 '16 at 03:38 PM

No, the plugins were not active in 4.9. I used the plugins only in 4.10.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

The issue you were experiencing in 4.9 is most likely fixed as of 4.10. For the errors you are seeing with the plugins, I would contact the plugin creators to see if this error has appeared with the plugins in other areas. For now I am going to mark this as answered, if you experience the initial error again in 4.10 or later, please post here with updated information.

more ▼

answered Jan 27 '16 at 05:51 PM

avatar image Kirby9890 May 30 '16 at 12:46 AM

Jumping on this a bit later but I had the exact same issue as I had a blueprint only project that would build fine with the development build but not the shipping build. I spent hours trying to get it sorted before finding the solution here.

I added in an empty C++ class and tried rebuilding the project but then the project failed to build and in the log under the user/appdata folder it said that there was a missing UE4Engine-ProjectName.dll file before exiting. So I closed and restarted the editor and it then said UE4Engine-ProjectName.dll was either built with an old engine version or is missing, would I like to rebuild it, clicked yes. Then the project loaded up in the editor. Then I packaged the project for Win64 and the executable ran fine.

So it would appear that the issue is still present in 4.11.2 for blueprint only projects.

avatar image polygon May 30 '16 at 06:18 AM

Thank you for your feedback! Unfortunately I can confirm this strange behaviour in 4.11.2 and I was struggling with the same problem a few days ago. This does not happen to all projects but some are affected by this weird issue. So far I could not figure out the reason behind this but hopefully you Epic guys can :)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question