x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4 Installer won't work, it begins DirectX then rolls back

Hello there!

I just purchased UE4 and I'm really excited to start using it. But I have this problem that some other people is having.

Basically, I run the installer (UnrealEngineInstaller-1.1.0-2054669.msi) and once it reaches the DirectX installation, it prompts me with the "There is a problem with this Windows Installer package..." and then rolls back everything.

Just so everyone knows, I've tried everyone's solution, including:

  • Placing the Installer in the C:/ root.

  • Launching it by using cmd as an administrator using the line: "msiexec /i C:\UnrealEngineInstaller.msi /L*V C:\UnrealEngineInstallerLog.txt"

  • Re-downloading the Installer.

  • Updating the drivers.

Maybe I'm doing something wrong, but anyway, I can't upload the log file because it's too big.

I hope we can fix this, I wouldn't like to cancel my subscription and asking for a refund :(

And here's my DxDiag log:

DxDiagLog

Regards!

Product Version: Not Selected
Tags:
dxdiag.txt (45.2 kB)
more ▼

asked Apr 28 '14 at 09:11 PM in Installation & Setup

avatar image

Nebuchaddy
26 2 3 3

avatar image Nebuchaddy Apr 28 '14 at 09:34 PM

The thing is that if I don't click "OK" when it tries to roll back, the engine works just fine. I'm downloading the latest version now. I'll keep the error open and see what does it tries to roll back and see if the enginge still works. I'll update as soon as I can.

avatar image Nebuchaddy Apr 28 '14 at 09:40 PM

Also I stopped launching the Engine without closing the error. I don't want to break anything.

avatar image 0xDEADBEEF STAFF Apr 28 '14 at 09:34 PM

Would you mind posting the UnrealEngineInstallerLog.txt file that was generated when you run the following command: "msiexec /i C:\UnrealEngineInstaller.msi /L*V C:\UnrealEngineInstallerLog.txt"

avatar image Nebuchaddy Apr 28 '14 at 09:36 PM

I can't, the file is too big, is like 2,5MB.

avatar image Stephen Ellis ♦♦ STAFF Apr 28 '14 at 09:48 PM

Try placing the log in a Zip file, and attaching the Zip.

Thanks

avatar image Nebuchaddy Apr 28 '14 at 09:50 PM

Ok didn't think about that. Here you go:

LogZip

avatar image 0xDEADBEEF STAFF Apr 29 '14 at 02:00 AM

According to your log, DirectX install is failing with error code -9. I did a bit of searching and it appears that the -9 error code for DXSetup.exe happens in two known cases. Perhaps you could check this out: http://support.microsoft.com/kb/177430

avatar image Alexander Paschall ♦♦ EPIC Apr 28 '14 at 11:28 PM

Can you tell us if this is related to the issue here:

https://answers.unrealengine.com/questions/25816/installation-stops-during-direct-x-set-up.html

Please try the solution on this page and let us know if it helps

avatar image Nebuchaddy Apr 28 '14 at 11:41 PM

I think it is not related. In that post, the problem comes when executing the Launcher.

As I said, when the installation reaches the DirectX part,it gives me the error and rolls back everything, deleting anything installed, so there's no launcher.

Anyway I've tried to download he DirectX Jun2010 Redist, and it doesn't work either.

Any other idea?

I'll post anything if something changes. Thanks for the help.

avatar image Nebuchaddy Apr 28 '14 at 11:42 PM

And, as I said before, if I prevent the roll back, UE4 seems to launch well. I'll try to sort something out of that. It'll need to download 4.1 files, but I'll try.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

UPDATE:

I managed to launch it. I did this:

I started installing UE4, and once it reached the roll back point, I left the error opened. Then I navigated to the installation folder and launched the launcher and waited for it to install the latest version. Once it finished, it started working, I played with it a bit and see the performance, everything seems fine. Then I closed the editor and clicked "OK" in the error pop-up from the installation. It rolled back the first installation, but it left the new files intact. Then I navigated again to the installation folder and made a shortcut to the Editor.

Error window: No "MSVCP120.dll" found. Solved by installing VCRedist_x64 (Visual C++).

The editor works now.

BUT

There is no Launcher, so I cant acces the Marketplace OR download the latest updates.

SO this is NOT a solution. I can use the editor,save projects and so on, but I cannot acces the Launcher or anything.

So I guess there are 3 options:

THE GOOD ONE: Fix the problem completly; once we figure the problem, I'll uninstall everything and put it back all together again. and maybe everyone has this sorted out, because it seems that a lot ot people are having the same issue.

THE QUICK ONE: Maybe the launcher executable. Raw files. Everything that the UE4 installer installs in a zip folder, so at least I can use the Marketplace and download the updates. If this is possible I prefer it to be a temporary solution, as we all mostly want what we payed for.

THE BAD ONE: Go with it as it is and hope for the best. (But really, no.)

I hope we sort it out. I can use the edior, even make full projects, but this is not the solution.

But as always, I'll try to upload any news and help however I can.

Thanks for the help everyone! We'll sort this out.

more ▼

answered Apr 29 '14 at 01:11 AM

avatar image

Nebuchaddy
26 2 3 3

avatar image tGardhouse Apr 29 '14 at 11:40 AM

Thanks for this update. I'm having the exact same issue. I've force-quit the installer at the error and the engine is currently downloading.

So far, this seems better than letting the installer roll back, as I have the launcher, marketplace, etc.

I'll update you once installation completes...

avatar image Nebuchaddy Apr 29 '14 at 01:12 PM

Ok, I managed to reinstall and keep the launcher by force.quitting it, now I have the launcher and the editor seems to work just fine.

BUT THIS IS NOT A SOLUTION

Even though the result seems equal to a fine installation, a lot of people have this problem and, of course, this is not the way to install the engine.

As far as I know, the possible problems are:

  • Permissions. I've read in other post that if your system is in another language, there may be problems with user groups.

  • Previous DirectX installations. Even though I've tried to manually install a previous version of DirectX, rebooting included, the installation seems to fail anyway. But maybe the problem is about the version of windows, the compatibility with drivers, or something else related to DX.

  • Installer. Maybe is just the .msi that is not well builded. Maybe it's resolved in another version of the installer.

As I said, I'll try to update if I figure out something.

Regards! And thanks!

avatar image tGardhouse Apr 29 '14 at 01:07 PM

The editor complains about an XAudio dll on load (and so I have no sound), but otherwise everything seems to be working.

Thanks for the temporary fix Nebuchaddy!

avatar image 0xDEADBEEF STAFF Apr 29 '14 at 01:50 PM

tGardhouse, would you be able to provide your installer log so we can confirm that you are seeing the same issue?

avatar image tGardhouse May 13 '14 at 02:39 PM

Sorry, I didn't notice your reply.

The current version of the installer works fine for me. I don't have the log any more, but on the plus side everything is fine for me now.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question