x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Compiling shaders

Every time I change a material on any object, it compiles 90+ shaders. This takes up a bit of my time. I've seen many topics about it, but no fixes. It didn't happen on my previous computer, but with my new computer, it won't stop.

Product Version: UE 4.10
Tags:
more ▼

asked Jan 23 '16 at 11:45 PM in Using UE4

avatar image

MasterCheif
13 5 6 9

avatar image teak421 Jan 24 '16 at 11:12 PM

You could always set your viewport to UNLIT until you really care about how it looks with lighting...

avatar image MasterCheif Jan 27 '16 at 11:05 PM

I tried and it still seems to be trying to compile shaders.

avatar image teak421 Jan 24 '16 at 11:40 PM

OR, go to your editor preferences and turn off apply lighting automatically.

avatar image MasterCheif Jan 27 '16 at 11:06 PM

How do I get to the Editor Preferences? I checked the "edit" tab at the top of my screen like the UE4 website told me to, but it wasn't there. Maybe it's because I'm using a Mac?

avatar image teak421 Jan 28 '16 at 05:57 AM

Hi... Go to the drop down menu EDIT and click EDITOR PREFERENCES. Then, LEVEL EDITOR - MISCELLANEOUS -- You will see a check box for APPLY LIGHTING AUTOMATICALLY. Try that.....

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I downloaded UE4 onto my newer computer and I no longer have this problem. It had to have been the graphics card. Thank you for your help!

more ▼

answered Dec 13 '16 at 03:06 AM

avatar image

MasterCheif
13 5 6 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question