x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Sound Cue: Noticeable gap when switching between sounds

I have a couple of sound effects cues wherein I have set up two sets of sounds. In one of the cues there is a set of 3 sounds (~3secs each) that are randomized, looped, then send to a mixer; there's also a set of 2 sounds (~4secs each) that are randomized, looped, then mixed. For some reason when this cue is played the 3 sounds will switch between themselves seamlessly, but the two have a noticeable gap/jump when they switch. I've checked the sound files and they're as they should be, and I've tried placing the looping node AFTER the mixer but this cause the shorter samples to switch whenever one of their samples finished AND when one of the longer samples from the other set would come to an end (meaning an obvious cut during the clip).

The second cue I have is of 3 sounds (~1sec each) being randomized, looped, and sent to a mixer, alongside one single sound (~2secs long) that loops itself and goes to the mixer. With this cue I have the same issue as above with the single sample looping fine but the three samples having a gap/jump whenever they switch.

Is this a known issue, or are their any known workarounds? I've discussed this with a fellow sound designer but we both ran out of ideas on how I may be able to fix the problem. Thanks.

Product Version: UE 4.8
Tags:
more ▼

asked Jan 24 '16 at 04:08 PM in Blueprint Scripting

avatar image

ktwAudio
6 1 2

avatar image teambrooklyn Feb 28 '16 at 04:59 AM
  • for me. UE 4.8.3 OSX10.10.5 . Is it a mac issue or an older engine issue?

avatar image JoshSDev Feb 20 '19 at 01:56 AM

Still no solution to this in January '19, UE4.21.1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question