x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Launching Standalone, cook, and package fail

I have done some searching and trying things from other posts on failures.

My project uses the engine from the Launcher, 4.1. It has C++ and Blueprints. It also does procedural generation / dynamic placement of meshes etc. at runtime.

I have seen other posts with problems running standalone that are also generating the level at runtime.

When I try to cook, I get the UAT error. When I try to run development from Visual Studio it can't find .dlls.

I attached the log when trying to run standalone from the Editor.

By the way, Shipping and Development will compile from Visual Studio, I just cant run them without crashing.

Thank you,

link text

Product Version: UE 4.10
Tags:
more ▼

asked Jan 25 '16 at 05:36 AM in Packaging & Deployment

avatar image

mikepurvis
2.5k 102 67 261

avatar image FilipeTessaro Jan 25 '16 at 11:44 AM

when you try to package, does it says that you just install VS2013? or no message appears?

avatar image mikepurvis Jan 26 '16 at 12:35 AM

It goes through a process, then after a few minutes it fails. I put the crash log in the attached zip file.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

There were two things preventing it from closing. There was a C++ error, but that still let it compile and run.

It was with the UFUNCTION macro, so I guess Visual Studio let it run even though there was an error. The function declaration didn't match the Blueprint specifier that I had.

There was an asset from near the beginning of the project, it was just a test piece of geometry for procedural spawning. It's reference was bad, deleting it fixed the crash.

Problem is resolved, game cooks, packages and runs standalone. ;)

more ▼

answered Jan 26 '16 at 01:01 AM

avatar image

mikepurvis
2.5k 102 67 261

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question