x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.11 quits without error or log

Hi!

I'm having difficulties to test my project (Marketplace link) in 4.11 Preview 3. My problem is, that when i press play in my project and drive the car some meters, the direction doesn't matters, it will always just quit and leaving me without any error or log report, so i can't see what was the cause of this behavior.

Here is the video: Video.

Product Version: UE 4.11 Preview
Tags:
more ▼

asked Jan 26 '16 at 04:59 PM in Bug Reports

avatar image

Balint3DDesign
42 8 13 19

avatar image Adam Davis STAFF Jan 26 '16 at 09:49 PM

Hi Balint3DDesign,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project in particular.

  • Can you post the crash logs here? They can be found at \Unreal Projects\PROJECTNAME\saved\logs.

  • What steps can I take to reproduce this error on my end?

  • Do you have any circular dependencies in your project? Is there any location where you are performing an action that could be problematic, such as dividing by zero or creating an infinite loop?

avatar image Balint3DDesign Jan 27 '16 at 04:52 PM

Hi!

  • It only occurs in this project.

  • Here you can download the Crash Logs: mega.nz

  • Because this occurs only in this project for me, i can send you my project files to you through the Forums by PM if it's okay for you. (If yes, which version should i link? 4.10 or the converted 4.11)

  • My project didn't have any circular dependencies, in older versions of the engine from 4.8 - 4.10 it works fine.

avatar image Adam Davis STAFF Jan 27 '16 at 06:05 PM

Were there any updates you made just before this crash started occurring? In your logs I am seeing a reference to a ParticleTrail2EmitterInstance.cpp. Do you have a particle trail attached in the level that could be firing? If so try removing this particle system and see if the crash occurs again.

avatar image Balint3DDesign Jan 27 '16 at 06:42 PM

No i haven't made any update to my project before the crash started occuring. I have 4 trail particle emitter attached to my car and this are the cars skidmarks, if i don't let those fire the crash goes away. Also something isn't right with the cameras, because now i can see some serious shake/jumps on all of the 3 cameras.

avatar image Adam Davis STAFF Jan 27 '16 at 06:55 PM

How are you calling the particle systems? Most likely the camera issue is not directly connected to the crashes.

avatar image Balint3DDesign Jan 27 '16 at 07:02 PM

I'm just enabling/disabling it's visibility, based on some factors, like speed, brake, steering. Also i have wrote a PM with my project file, so you can take a look into that too.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I was able to reproduce this on my end and have entered a bug report, UE-26105, to be assessed by the development staff. It seems that even simply opening the Tireskid particle system will crash the editor, though this produces a callstack. I would remove this asset from your game for now so you can continue moving forward. All other particle systems in the same folder seem to be working as intended.

more ▼

answered Jan 27 '16 at 07:56 PM

avatar image Balint3DDesign Feb 02 '16 at 07:36 PM

I was able to solve this by recreating the particle system and it worked as it was before just needed to lower the particle count, though i discovered that if i use around 200 particle count on the ribbon data it will immediately crash the engine.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question