x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

All "physics" bones set to no collide, model still explodes

The model was made and rigged in Blender. All transformations have been "applied", both for the mesh and the skeleton. The model was imported with the scale 1.0. The physics bodies where all set to no collide, also tried to make them simply not overlap (same result). Here are some pictures to illustrate it better: alt text alt text alt text Anyone have any ideas? Google was of no help.

Product Version: UE 4.10
Tags:
woot.png (347.7 kB)
woot2.png (347.4 kB)
armature.png (430.0 kB)
more ▼

asked Jan 26 '16 at 09:10 PM in Using UE4

avatar image

Krachn
6 4 6 11

avatar image Krachn Jan 26 '16 at 09:32 PM

Seems like ue4 warps the skeleton too, any ideas of why it does that? (Second picture from inside blender) alt text

alt text

pleasesendhelp.png (480.5 kB)
whygodwhy.png (48.5 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello, if you can post a screenshot of your skeleton in Unreal that would be great as well as whole Phat set up, but what I think could be the problem is the Physics body of the Armature itself. As I think you already find out Unreal creates one more bone named after Armature object created in blender. So in Blender it is only object for you to know about, but after export it turns into a bone. You can either just delete its body in Phat editor in Unreal, or you can delete your root bone in Blender and rename the armature object after that deleted bone, so the verticies in Unreal will stay assigned to the newly created root bone.

more ▼

answered Apr 08 '16 at 07:56 PM

avatar image

Ligazetom
82 8 13 16

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had a similar problem. The bones just ejected away and stayed there.

The caouse of the problem in my case was in Blender. In the Properties panel, under Scene tab, there is a Units section. You have to set the scale to 0.01. Then you obviusly have to scale your model and armature 100x.

You can leave all other settings as they are, but in the export options, I prefear to turn off "add leaf bones". That just creates aditional bones on the end of each bone chain and I don't know what that's good for.

Hope that helped!

more ▼

answered Jul 04 '16 at 01:07 PM

avatar image

TimberTuc
13 3 5 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question