x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Client loading incorrect map while connecting to server

Expected Behavior: When a client connects to a server the client will automatically load the map that the server is running. (Multiplayer Shootout Game youtube video at 17:27).

Actual Behavior: The client reloads the map that it was running when it connected to the server (usually a level titled something like 'MainMenu'). .

Steps to Reproduce:

  1. Create new MultiplayerShootout project (version 4.10.2)

  2. Load map 'MainMenu'

  3. Change Play->Number of Players to '2'

  4. Select Play->New Editor Window (PIE)

  5. Select Play->Advanced Settings

  6. Change 'Standalone Windows Size' to 640x360

  7. Uncheck 'Always center window to screen'

  8. Change Standalone Window Position to 1100x0

  9. Uncheck 'Auto Connect To Server'

  10. Close 'Editor Preferences' window

  11. Click 'Play'. Two windows appear, both displaying the main menu

  12. Click the 'Play' button on the left window. Level_01 will load. Orange cowboy will be ready to draw.

  13. Click the 'Find Games' button on the right window (there is often a problem with the cursor disappearing at this point. I am not concerned about this at the moment, I use tab and arrow keys). One server will display in the list.

  14. Click the server in the list. Orange cowboy will appear in the window on the left (server). Right window is black with MyHUD displayed. If the game is played on the server window projectiles will replicate on the client, score will also replicate. In my personal project I can control my client's actor (the server version) by focusing the client window and using the keyboard and mouse. Of course the client window is just black (as the level that I used to connect to the server has nothing in it)

General Thoughts: I believe MultiplayerShootout was working correctly earlier (within the last day or two). Maybe I'm wrong about this, maybe I'm just too drunk to remember correctly. I started to implement logic similar to MultiplayerShootout in a personal project. I noticed that whenever a client connected to a server the BeginPlay event of the MainMenu map (which is the map that was loaded when the client tried connecting to the server) would get called and the client would display a black screen (which is correct for the MainMenu map). I went back to MultiplayerShootout and experienced the same behavior. I opened projects that I haven't worked on in weeks which connect using OpenLevel?listen and ExecuteConsoleCommand (no session nodes) and they now behave the same (client reloads level that was open when connection to server was requested). Before this I had never used the session nodes or had Steam entries in any DefaultEngine.ini file. I'm not sure if I messed something up at the computer level or if there is just a bug in my projects. When I package MultiplayerShootout, start two instances and create a server and client the client connects as expected. Any help with this issue is greatly appreciated.

Verbose log is at http://pastebin.com/ATTxSnDz

TLDR; my sh*t be wack

Product Version: UE 4.10
Tags:
more ▼

asked Jan 27 '16 at 04:58 AM in Bug Reports

avatar image

Yokozuna
1 1 1 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Yokozuna,

I was able to reproduce this issue on our end. I have written up a report ( UE-26083) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. I have also provided a potential workaround that may be viable depending on your needs. Thank you for your time and information.

Workaround:

You could use the launch game feature by right clicking the the uproject to launch two copies of the project for testing.

alt text

Note: This issue did not appear to be that the incorrect map was being loaded. Instead the issue was that there was not lighting in the level. This is subject of the report mentioned above.

Make a great day

mpshootouthelp.png (23.0 kB)
more ▼

answered Jan 27 '16 at 03:55 PM

avatar image

Rudy Q ♦♦ STAFF
47.2k 545 132 525

avatar image SantaCop Mar 04 '16 at 05:01 AM

Is this issue solved?

avatar image Rudy Q ♦♦ STAFF Mar 04 '16 at 02:45 PM

Hello SantaCop,

I went ahead and double checked on this issue for you. It appears that this issue's status has not yet been updated to fixed. However, I will be sure to bump up the community interest for you.

Make it a great day

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question