x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to change games culture without restart in UE 4.11?

Hello.

I found a lot of questions on this problem, but solution, that suggested in those answers, doesn't work for me.

I tried

  FInternationalization::Get().SetCurrentCulture(TEXT("pl"));

but it doesn't solved my problem. Console command

 CULTURE=en 

also doesn't helped me.

How to change culture in UE 4.11 in game runtime, without restart?

Thank you!

Product Version: UE 4.11 Preview
Tags:
more ▼

asked Jan 27 '16 at 04:24 PM in Using UE4

avatar image

Arthur Khusnutdinov
610 91 96 252

avatar image Shadowriver Jan 28 '16 at 04:01 AM

Maybe try to reload entry level, or atleast reinitiate all the widgets

avatar image Arthur Khusnutdinov Jan 28 '16 at 07:54 AM

Hi! Re-initialization of the widgets not solved the problem... alt text It still showing texts in "en" culture. But if I restart game with -culture=ru-RU - it showing texts in needed culture, ie my translation works correctly.

1.png (29.8 kB)
avatar image Arthur Khusnutdinov Jan 28 '16 at 07:58 AM

Level re-opening also not solved the problem: alt text

1.png (39.4 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

@Arthur Khusnutdinov, did you solve it?

For people with this kind of problem and similar, somethings worth checking out (I stumbled upon two of them):

  • Remember to compile your translations (I do it on the Localization Dashboard)

  • In Project Settings > Packaging > Packaging > Advanced Settings check if your translations are checked in the Localizations to Package list (easier to see pressing Show localized)

  • In the same place, set Internationalization Support to something that covers all your languages. In my case (pt-BR), I thought EFIGS would do the trick, as Portuguese has similar glyphs to Spanish. But no. It's a very specific setting. So, I had to use All.

  • The culture/language won't change in editor, so test in Standalone Preview. For VR you need to build the project, unfortunately.

more ▼

answered Jul 16 '16 at 03:05 PM

avatar image

RVillani
1.1k 28 41 90

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello, I don't know if it could helps you but by my side (UE 4.11.2) : To preview a culture without restarting UE I use the "Preview in Editor" Button in the Translation Editor :

  1. Enter -culture=it in the console command on the OutputLog tab (here it : italian for the exemple)

  2. open The Localization dashBoard

  3. Edit Translation you want to preview

  4. Then Clic on the "Preview in Editor" Button Preview in Editor

culture1.jpg (42.1 kB)
more ▼

answered Apr 27 '16 at 07:04 PM

avatar image

tefica
153 8 10 16

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question