x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Skeletal Animation only FBX import not working

Hi, animation only fbx imports are still not working since 4.7. Basically, if you try to import animations that does not include the mesh, the engine throws off the below error message. I still use 4.7 to import my skeletal animation and then migrate it over to current engine build.

I would like to have it the ability to export anims only, again to avoid unnecessary large fbx files used in source control.

Thanks!

Engine: 4.11 Preview 4

Example of error: "Failed to import 'C:\Dev\Models\LocustShip\Game\Anims\Aim\AimCenterUp.fbx'. Failed to create asset '/Game/Char/AimCenterUp'"

Product Version: UE 4.11 Preview
Tags:
more ▼

asked Jan 27 '16 at 05:16 PM in Bug Reports

avatar image

Devero
2.3k 114 62 234

avatar image Steve Hardister ♦♦ STAFF Jan 27 '16 at 07:47 PM

Hi Devero,

I tried to recreate what you are doing in UE4.6, but like the current version of the engine, a skeleton must already be present in the engine to assign an animation to. You do not always need to import a skeletal mesh. Again as long as the skeleton is present in the project, you can import the animation (or animations) without a skinned skeletal mesh attached and select the existing skeleton from the dropdown menu in the import options pop-up screen.

If I am not understanding the issue, please provide some repro steps I can follow to recreate the issue on our end.

Thanks,

Steve H.

avatar image Devero Jan 27 '16 at 08:53 PM

Thanks for the quick reply. Basically, I do import a base skeleton mesh without animation. This does create a skeleton for me.

The problem is when I import animations afterwards which is animation only with out the reference mesh, it errors. Now everything works 4.7 and earlier. However, 4.8, 4.9, 4.10, & 4.11 does not and gives that previous error message. If you try it on 4.6 it should work, but I'm currently using 4.10 as my base engine.

avatar image Devero Jan 27 '16 at 08:58 PM

The repro steps: Pipeline from Maya:

1) Select root bone, then select bone hierachy to select all bones 2) Then add select the skinned mesh 3) Export the FBX from Maya

... Import into UE4 4.10 version this "Mesh" FBX which works fine and creates the required skeleton and mesh references.

4) Now Back in Maya, create an Animation on the skeleton 5) Select the root bone, then select bone hierachy to select all bones 6) DO NOT SELECT the mesh this time and just export out the animation as FBX.

7) Now try to import that FBX into UE4, and it will bring up the previous error message. It doesn't even get to the import options dialog on the error.

I hope that helps explain the process better. =)

Also I'm using the FBX 2014/2015 exporter, since the last I checked 2016 wasn't supported yet.

Again, all of this works in 4.7 and before.

avatar image Steve Hardister ♦♦ STAFF Jan 27 '16 at 09:37 PM

I'll be happy to delve into this and repro when I have a little more time, but my first response, as a workaround, would be:

  1. Make a copy of the scene with the skinned mesh performing the animation (always keep a copy where the skin is applied and weighted)

  2. Unbind skin and delete mesh

  3. Export just animated bones

  4. When importing into UE4.10, select skeletal mesh

Let me know if this does not work. I think the error is being generated because it is expecting the skinned mesh because there is data saying that skin is bound to the skeleton but there is not actual "skin" present.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I was unable to reproduce the issue using your repro steps: In my test, the skeleton is still present from your step 1. Then I import the animation that I selected bones only (no mesh.) In the import options, I selected the skeleton from test 1, when prompted, and animation alone imported since the skeletal mesh and skeleton were already present in the Conten Browser.

If you are still having issues, try the workaround I posted before and let me know your results. If I did not reproduce the issue accurately, let me know what I need to do different and I'll try to repro the bug again. -Thanks.

more ▼

answered Jan 28 '16 at 06:01 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question