x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

I am trying to debug UE4.10.2 game project using Xcode 7.2. Stepping through code is not giving the value of variables correctly.

Before stepping the code begins, I get the warning: "UE4Editor-QuickStart.dylib was compiled with optimization - stepping may behave oddly; variables may not be available."

I have tried using as Build Configuration both the "DebugGame Editor" and "Development Editor" and they both seem to be not storing debug information.

Is there a way for getting the debug information back? I am just looking to step through the code and examine values of the variables. This worked perfectly well in UE4.8.3 and Xcode 6.4

Product Version: UE 4.10
Tags:
more ▼

asked Jan 28 '16 at 12:57 AM in Installation & Setup

avatar image

gillsguitar
43 2 2 4

avatar image Matthew J ♦♦ STAFF Jan 28 '16 at 07:41 PM

Hello gillguitar,

I can confirm that I'm getting the same message and behavior when trying to debug with XCode. While I'm not familiar with debugging on XCode as I've never tried it before, I'll be looking into how to fix this. I'll be sure to let you know as soon as I found out anything.

avatar image gillsguitar Jan 28 '16 at 08:19 PM

Thank you. I appreciate your looking into this!

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

It seems that with XCode, the commandline arguments are not changed by a config-by-config basis as they are with Visual Studio. This means that when you change to DebugGame or any configuration you wish to use, you'll need to also add the "-debug" commandline argument.

After doing that, the message disappeared for me and I was able to see my variables' values.

more ▼

answered Jan 29 '16 at 09:05 PM

avatar image

Matthew J ♦♦ STAFF
31.8k 526 92 417

avatar image gillsguitar Jan 29 '16 at 10:41 PM

Thank you, that works like a charm! For future users who may stumble onto this post, here is where the "-debug" needs to be added: 1) Click on your project name on top-left of Xcode, then Edit Scheme. This opens up the configuration editor. By default the "Info" tab is open. 2) Go to the "Arguments" tab. 3) There is a field called "Arguments Passed on Launch" and it will be showing the path to .uproject file associated with your project. Double click on the path and insert -debug at the end. Example: "/Users/PCNAME/Documents/Unreal Projects/MyProject/MyProject.uproject" -debug

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question