x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Start menu not disapearing

alt text

made a simple start menu but when I click start game the menu doesn't go away and just stay's there

Product Version: UE 4.11 Preview
Tags:
untitled.png (351.5 kB)
more ▼

asked Jan 29 '16 at 03:26 AM in Blueprint Scripting

avatar image

Mrfarside44
3 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Try Remove From Parent before you open you level. I believe when you switch levels, you lose the instance of the widget. Although you can still see it in the viewport, as soon as you switch, the remove node never fires because the new level is starting a new Game Mode, Game State, HUD , etc. While this is a simple check to see if it works or not, you could also put a "Print String" after the Open Level node to see if it prints anything.

Hope this helps!

more ▼

answered Jan 29 '16 at 03:36 AM

avatar image

jtsmith
1.4k 70 29 92

avatar image Mrfarside44 Jan 29 '16 at 03:50 AM

well that some what worked, tested it in editor mode and worked fine but when I package it to test it it does the same thing again

avatar image jtsmith Jan 29 '16 at 03:52 AM

Right-click the main Content folder in the content browser and select "Fix Redirectors" then try again.

You may also want to delete your "Build" folder before packaging. Sometimes it won't rewrite the files when building/packaging.

avatar image Mrfarside44 Jan 29 '16 at 04:00 AM

done that, still the same thing. I'm noticing it loads the HUD for about a second then goes back to the menu

avatar image jtsmith Jan 29 '16 at 04:03 AM

I'm not quite sure then. All I do for mine is like I stated above and it works fine. Have you tried shutting down the editor, including the launcher and trying? Could be cached somewhere causing the issue. Could reset your PC just to ensure. If it's working in the editor, it should work in the package build.

avatar image Mrfarside44 Jan 29 '16 at 04:06 AM

yeah I'll try restarting everything, cause I'm having this issue with another open level blueprint of mine. Works in the editor but not when its packaged

avatar image jtsmith Jan 29 '16 at 04:33 AM

Another suggestion would be to delete the Intermediate folder as well and let the Editor rebuild that when you start. I was having some issues with building, albeit different issue, a staff member suggested that I delete this folder and try again. While I can't attest to it working or not (I just rebuilt my whole game from scratch) I am assuming it is safe to remove this folder and its files. Just in case, I would make a backup of it or just move it to a different location.

avatar image Mrfarside44 Jan 29 '16 at 04:39 AM

yeah I'm doing more testing and I think its something else, all my open level blueprints are not working. instead of opening the level that I'm telling it to load it simply just reloads the current level, including the menu. I'm just going to mark this as answered and start another thread since menu isn't the problem

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question