x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Build broken on Mac with BUILT_FROM_CHANGELIST non-zero

So I am having trouble building UE4Editor on Mac with BUILT_FROM_CHANGELIST set to a non-zero value. I am setting BUILT_FROM_CHANGELIST to the value of the most recent official build so that our DLLs/dylibs load properly into the current official build. I have built UE4Editor hundreds of times successfully like this on both PC and Mac, and it has worked great for the past year and a half, just today it suddenly began causing issues (actually after moving my development folder from one drive to another). See the error log attached below.

Essentially the error message is:

 LogModuleManager:Warning: Found module file /Volumes/Dev/UnrealEngine/4.11/Engine/Plugins/SkookumScript/Binaries/Mac/UnrealHeaderTool-SkookumScriptGenerator.dylib (API version 0), but it was incompatible with the current engine API version (2843242)

I have tried running with the -clean flag beforehand, manually deleting the dylib in question, deleting the Engine Intermediate and Binaries folder, deleting the plugin Intermediate and Binaries folders, but it always fails again with the dylib built apparently with BUILT_FROM_CHANGELIST set to 0. I have checked the date on the dylib and it's fresh (from a few minutes ago).

Pulling my hair out! Any help would be appreciated.

Thanks!

 a1011:4.11 zorro$ Engine/Build/BatchFiles/Mac/Build.sh UE4Editor Mac Development
 Setting up Mono
 Building UBT...
      0 Error(s)
 Building UE4Editor...
 2016-02-01 14:03:10.955 defaults[8229:74485] 
 The domain/default pair of (/Users/zorro/Library/Preferences/com.apple.dt.Xcode, IDEBuildOperationMaxNumberOfConcurrentCompileTasks) does not exist
 Running command : Engine/Binaries/DotNET/UnrealBuildTool.exe UE4Editor Mac Development -deploy
 Compiling with MacOSX SDK 10.11
 Building UnrealHeaderTool...
 Compiling with MacOSX SDK 10.11
 Performing 29 actions (8 in parallel)
 [1/29] Compile CorePrivatePCH.h
 [3/29] Compile Module.Projects.cpp
 [4/29] Compile Module.CoreUObject.1_of_4.cpp
 [6/29] Compile Module.CoreUObject.2_of_4.cpp
 [8/29] Compile Module.UnrealHeaderTool.cpp
 [7/29] Compile Module.CoreUObject.4_of_4.cpp
 [5/29] Compile Module.CoreUObject.3_of_4.cpp
 [2/29] Compile Module.Json.cpp
 [9/29] Compile Module.Core.2_of_7.cpp
 [10/29] Compile Module.Core.3_of_7.cpp
 [11/29] Compile Module.Core.1_of_7.cpp
 [12/29] Compile Module.Core.5_of_7.cpp
 [13/29] Compile Module.Core.6_of_7.cpp
 [14/29] Compile Module.Core.4_of_7.cpp
 [15/29] Compile Module.Core.7_of_7.cpp
 [16/29] Compile Module.SkookumScriptGenerator.cpp
 [17/29] Link UnrealHeaderTool-Core.dylib
 [18/29] Link UnrealHeaderTool-Json.dylib
 Generating UnrealHeaderTool-Core.dSYM
 [20/29] Link UnrealHeaderTool-Projects.dylib
 Generating UnrealHeaderTool-Json.dSYM
 [22/29] Link UnrealHeaderTool-CoreUObject.dylib
 Generating UnrealHeaderTool-Projects.dSYM
 [24/29] Link UnrealHeaderTool
 [25/29] Link UnrealHeaderTool-SkookumScriptGenerator.dylib
 Generating UnrealHeaderTool-CoreUObject.dSYM
 Generating UnrealHeaderTool-SkookumScriptGenerator.dSYM
 Fixing dylib dependencies for UnrealHeaderTool
 Generating UnrealHeaderTool.dSYM
 -------- End Detailed Actions Stats -----------------------------------------------------------
 Total build time: 122.03 seconds
 Compiling with MacOSX SDK 10.11
 Deploying now!
 Parsing headers for UE4Editor
   Running UnrealHeaderTool UE4Editor "/Volumes/Dev/UnrealEngine/4.11/Engine/Intermediate/Build/Mac/UE4Editor/Development/UnrealHeaderTool.manifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended
 Ensure condition failed: RegisterMountPointDelegate.IsBound() [File:/Volumes/Dev/UnrealEngine/4.11/Engine/Source/Runtime/Projects/Private/PluginManager.cpp] [Line: 476] 
 LogOutputDevice:Warning: === Handled error: ===
 Ensure condition failed: RegisterMountPointDelegate.IsBound() [File:/Volumes/Dev/UnrealEngine/4.11/Engine/Source/Runtime/Projects/Private/PluginManager.cpp] [Line: 476]
 Stack: 
 FDebug::OptionallyLogFormattedEnsureMessageReturningFalse(bool, char const*, char const*, int, wchar_t const*, ...)[/Volumes/Dev/UnrealEngine/4.11/Engine/Source/Runtime/Core/Private/Misc/OutputDevice.cpp, line 441] [in UnrealHeaderTool-Core.dylib]
 FPluginManager::ConfigureEnabledPlugins()[/Volumes/Dev/UnrealEngine/4.11/Engine/Source/Runtime/Projects/Private/PluginManager.cpp, line 476] [in UnrealHeaderTool-Projects.dylib]
 FPluginManager::LoadModulesForEnabledPlugins(ELoadingPhase::Type)[/Volumes/Dev/UnrealEngine/4.11/Engine/Source/Runtime/Projects/Private/PluginManager.cpp, line 517] [in UnrealHeaderTool-Projects.dylib]
 FEngineLoop::AppInit()[Runtime/Launch/Private/LaunchEngineLoop.cpp, line 3014] [in UnrealHeaderTool]
 FEngineLoop::PreInit(wchar_t const*)[Runtime/Launch/Private/LaunchEngineLoop.cpp, line 1177] [in UnrealHeaderTool]
 tchar_main(int, wchar_t**)[/Volumes/Dev/UnrealEngine/4.11/Engine/Source/Programs/UnrealHeaderTool/Private/UnrealHeaderToolMain.cpp, line 60] [in UnrealHeaderTool]
 main[/Volumes/Dev/UnrealEngine/4.11/Engine/Source/Programs/UnrealHeaderTool/Private/UnrealHeaderToolMain.cpp, line 18] [in UnrealHeaderTool]
 start Address = 0x976d25ad (filename not found) [in libdyld.dylib]
 LogModuleManager:Warning: Found module file /Volumes/Dev/UnrealEngine/4.11/Engine/Plugins/SkookumScript/Binaries/Mac/UnrealHeaderTool-SkookumScriptGenerator.dylib (API version 0), but it was incompatible with the current engine API version (2843242). This is likely a stale module that must be recompiled.
 LogCompile:Error: Failed to initialize the engine (PreInit failed).
 Error: Failed to generate code for UE4Editor - error code: CrashOrAssert (3)
 UnrealHeaderTool failed for target 'UE4Editor' (platform: Mac, module info: /Volumes/Dev/UnrealEngine/4.11/Engine/Intermediate/Build/Mac/UE4Editor/Development/UnrealHeaderTool.manifest).
 a1011:4.11 zorro$ ls -l /Volumes/Dev/UnrealEngine/4.11/Engine/Plugins/SkookumScript/Binaries/Mac/UnrealHeaderTool-SkookumScriptGenerator.dylib 
 -rwxr-xr-x  1 zorro  staff  428692 Feb  1 14:05 /Volumes/Dev/UnrealEngine/4.11/Engine/Plugins/SkookumScript/Binaries/Mac/UnrealHeaderTool-SkookumScriptGenerator.dylib
Product Version: UE 4.11 Preview
Tags:
more ▼

asked Feb 01 '16 at 11:28 PM in C++ Programming

avatar image

GreatGuru
115 10 12 19

avatar image GreatGuru Feb 02 '16 at 12:15 AM

Update: I completely nuked my UE 4.11 root folder and did a clean checkout from git. Still happens.

avatar image GreatGuru Feb 02 '16 at 01:41 AM

Also note how the build step counter is off on Mac. Build is done when it reaches [25/29]. This does not happen on PC.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Ok the solution was to modify the change list number in Engine/Build/Build.version to be consistent with the one specified in Version.h, then clean UHT via Engine/Build/BatchFiles/Mac/Build.sh UnrealHeaderTool Mac Development -clean and build.

more ▼

answered Feb 05 '16 at 04:37 AM

avatar image

GreatGuru
115 10 12 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question