x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Workspace not found with P4 and Assembla

Hello,

I have a few people working with P4 and assembla but for the life of me we can't get one member working with the UI in Unreal for connecting to P4

We have a good connection with the user to P4, he can log in fine, it's just when looking for the appropriate workspace within UE it comes up empty.

We tried to manually add the workspace and add it into the P4config.txt but still coming up short.

Any advise would be appreciated! Thanks!

Product Version: UE 4.10
Tags:
more ▼

asked Feb 03 '16 at 12:22 AM in Installation & Setup

avatar image

elgreeno
31 5 8 9

avatar image Matthew J Feb 03 '16 at 02:49 PM

Hello elgreeno,

Just to be sure, is the project that this member is opening when trying to set his perforce connection a project that is part of the workspace he is trying to connect to? Usually if that is the case, the workspace will automatically be populated.

Are there any obvious hardware/software differences between this member's computer and the computers that are working correctly?

avatar image Matthew J Feb 08 '16 at 07:43 PM

We haven't heard from you in a while, Elgreeno. Is that one member of your group still having this issue? If so, could you provide some of the information requested in my previous comment? In the meantime, I'll be marking this as resolved for tracking purposes. Please feel free to comment and the post will reopen.

avatar image elgreeno Mar 21 '16 at 03:14 PM

Hello!

Yep the project loaded is the same project in P4. The P4 connection to the Assembla server is fine. It's finding a workspace in the P4 UI in Unreal which is the issue.

A new person joined the P4 project and they too now have this issue as well.

avatar image Matthew J Mar 22 '16 at 06:23 PM

Hello elgreeno,

Could you have those team members each try to connect once more and when they receive an error message or anything of the sort, have them close the editor and provide their log files from the project's directory > Saved > Logs? The log files may be able to give some insight on what is causing the problems you're running into. Also, are there any differences in permissions or hardware/software between these users' computers and yours that could be causing the problem?

avatar image elgreeno Mar 30 '16 at 01:59 AM
dan_logs.rar (238.0 kB)
avatar image Matthew J Mar 30 '16 at 01:31 PM

Thank you for the logs. While they weren't able to tell me much, I did ask another team member if they had an ideas about this and they mentioned that using Assembla with P4 can sometimes require some extra steps. When opening the Source Control Login and after selecting your Provider, the list of fields should appear but there should also be a down arrow that you can click to expand with two more options. This is used for Host Impersonation and will be required by Assembla. From Assembla's documentation, the information for this can be found in the Instructions tab for your Perforce repository in Assembla.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

We haven't heard from you in a while, elgreeno. Are your team members still experiencing this issue? If so, could you provide the information I asked for in my previous post? In the meantime, I'll be marking this issue as resolved for tracking purposes.

more ▼

answered Mar 29 '16 at 06:35 PM

avatar image elgreeno Mar 30 '16 at 01:58 AM

sorry repoening with the log files

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question