x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4Editor-Engine.exp missing

I am trying to run the Hairworks branch of Unreal Engine 4, but when I try to build it it gives me an error saying failed to produce UE4Editor-Engine.exp and fails to build. I have tried re-running the setup files and generating the project files, but they still do not seem to create the needed file.

Product Version: Not Selected
Tags:
more ▼

asked Feb 05 '16 at 02:59 AM in Installation & Setup

avatar image

ShotgunHR
31 2 3 5

avatar image ShotgunHR Feb 08 '16 at 05:40 AM

bump because it still isn't working.

avatar image Matthew J Feb 08 '16 at 04:42 PM

Hello ShotgunHR,

Could you post the full output log from when you try to build? There should be something in there telling us where the problem is occurring.

avatar image ShotgunHR Feb 10 '16 at 09:32 PM

Thank you. it is actually the exact same issue as the question here

(I'm not sure where to find the output log. I'm an artist not a programmer lol).

avatar image Matthew J Feb 11 '16 at 03:18 PM

Thank you for providing that information. Are you downloading the source from here?

https://github.com/NvPhysX/UnrealEngine/tree/HairWorks

If so, just to be sure, are you running the Setub.bat, and then the GenerateProjectFiles.bat and then attempting to compile the project (the .sln file) in Development Editor for the Win64 platform? You should be able to find those settings at the top of Visual Studio, on the toolbar as part of a dropdown.

Also, to find the Output log, you should be able to see it at the very bottom as one of the tabs such as "Error List" and "Output". If it isn't there, you can open it with the Ctrl + Alt + O hotkey as well.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Thank you for your help. The OP of the other post provided me a fix for it and now it works perfectly! One of the cpp files was not including a header file it needed.

more ▼

answered Feb 12 '16 at 12:36 AM

avatar image

ShotgunHR
31 2 3 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question