x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Very hard shadows on some Static Meshes

I have a problem regarding some static meshes. They seem to have no regular shadow or light falloff, but instead a sharp edge for the shadow. They are created in Blender and they use the exact same export settings as many other meshes, which have no problems at all.alt text

I've tried several things to solve this, but it does not seem to be connected to a material or normal map issue. I've also tried to increase the light map, tried recomputed tangents and normals, but nothing works. Does anybody know what causes this strange shadow casting on the mesh and how to solve this?

Product Version: UE 4.10
Tags:
saege3.jpg (239.4 kB)
more ▼

asked Feb 05 '16 at 11:55 AM in Rendering

avatar image

Blue669
251 29 39 54

avatar image FilipeTessaro Feb 05 '16 at 12:52 PM

Increased the lightmass resolution of the table, where the shadow is being casted? Maybe it is the UV channel too, try to import the mesh again to generate a new UV channel

avatar image Blue669 Feb 05 '16 at 03:03 PM

Thanks but I've already tried that. Does not change anything. Here is another screenshot from a different static mesh. They all have the same issue, but other meshes are working normally. alt text

waschmacsh.jpg (267.2 kB)
avatar image FilipeTessaro Feb 05 '16 at 03:18 PM

looks like the UV channel

avatar image Blue669 Feb 05 '16 at 04:01 PM

How can I fix it? Generate Lightmap UV option when importing is checked by default. When I uncheck it, it still has the same issue.

avatar image FilipeTessaro Feb 05 '16 at 04:50 PM
avatar image Blue669 Feb 05 '16 at 05:24 PM

I've tried it, but the issue is still the same.

avatar image FilipeTessaro Feb 05 '16 at 05:25 PM

sorry to hear that...

well, tried to change the mesh to movable and rebuild the lights to see if anything changes?

avatar image Blue669 Feb 05 '16 at 06:35 PM

The mesh is already movable. The lights are 100% dynamic, nothing to build there ;)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Ok here is the solution: even if you use a normal map, you got the set the shading for large flat surfaces to flat inside your 3d program

alt text

saegefix.jpg (294.9 kB)
more ▼

answered Feb 08 '16 at 11:26 AM

avatar image

Blue669
251 29 39 54

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question