x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE Crashes when Set Skeletal Mesh is called

Hi!

I'm experiencing some strange bug/crash in UE4. It only happens, when i want to switch out a mesh with a "Set Skeletal Mesh" node using a button. In the Crash/Log report it only says "Fatal Error". Here is the Crash log: mega.nz Also it seems that the engine version doesn't matter.

Product Version: UE 4.10
Tags:
more ▼

asked Feb 06 '16 at 01:34 PM in Bug Reports

avatar image

Balint3DDesign
42 8 13 19

avatar image Ben Halliday STAFF Feb 07 '16 at 02:56 AM

Hi Balint3DDesign,

A few questions/requests:

  1. Please copy/paste the Machine ID from the Crash Reporter window here after this crash occurs, and be sure to Send the report.

  2. Does this occur in a new project, or only your current project?

  3. Does this depend on a specific skeletal mesh, or will any reproduce the crash?

  4. Can you give us some specific steps to follow that will reproduce this in a new project?

  5. You mention that engine version doesn't seem to matter. Can you tell us which versions you've had this same crash occur, in the same way?

Thanks!

avatar image Balint3DDesign Feb 07 '16 at 09:10 AM

Hi Ben Halliday,

  1. MachineId:A8F463BC455E7991CA6F82BFCA75908F

  2. It only occurs in my project.

  3. I have tried tried it with multiple skeletal mesh, but all of those were creating a crash.

  4. Used the button "4" to call the "Set Skeletal Mesh" node with a flip flop, so i can switch the mesh with one button, but i will send the project files in PM, so you can take a look into that.

  5. From 4.8 to 4.11 Preview versions get an instant crash when the "Set Skeletal Mesh" node was called.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

HI Balint3DDesign,

I was able to reproduce this error and have entered a bug report, UE-26640, to be assessed by the development staff. I noticed that if you switch the skeletal meshes being called, the editor will crash upon compiling the blueprint as well, so it may be tied directly to the skeletal meshes being used. I am entering a second bug report, UE-26642, to be assessed as well.

more ▼

answered Feb 08 '16 at 07:41 PM

avatar image dimin69 Jun 27 '17 at 09:13 PM

hello , has this issue been fixed as of yet?

i am having a similar issue

(comments are locked)
10|2000 characters needed characters left

Hello guys, i was having this problem too. If your character is doing any animation while he is changing the mesh, let the option: "Reinit Pose" unselected.

alt text

pose.png (55.7 kB)
more ▼

answered Nov 20 '18 at 01:47 AM

avatar image

GuaiamuStudio
85 5 9 16

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question