x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

UE 4.8.3 HTML5 game not working

I want to compile my pure-blueprint game to HTML5. Packaging ends with success, but after launching the game only the main menu works quite well - after clicking "play" button there's a black screen with HUD and after a second I'm being returned back to the menu.

I've installed Emscripten 1.29.0 and Python 2.7.11, as said in your specification. Also I've added a lines in HTML5Engine.ini: [BuildSettings] HeapSize=2048

What can I do? I'll be very glad for any help!

Product Version: UE 4.8
Tags:
more ▼

asked Feb 06 '16 at 10:26 PM in Packaging & Deployment

avatar image

MrDark
1 1 2

avatar image Samantha Sutton ♦♦ STAFF Feb 22 '16 at 08:57 PM

Hey MrDark,

Is the issue that you're running into the fact that the second map isn't working, or the fact that the game isn't loading on HTML5? Could you please provide some additional information and perhaps the web address to view your project?

Thanks!

avatar image MrDark Feb 23 '16 at 01:19 PM

Probably the second map isn't working - menu seems to work fine. However, when I tried to rebuild it after launching I've got an error "Assertion failed: Cannot call unknown function on_fatal (perhaps LLVM optimizations or closure removed it?)".

I'm including build log and HTML5Engine.ini Link to the web project: http://orion.fis.agh.edu.pl/~1Solarz/Magistallum.html

avatar image Samantha Sutton ♦♦ STAFF Feb 23 '16 at 09:07 PM

Thanks for providing me all of that information, it's been very helpful. Sometimes when I press on the PLAY button, the level doesn't even load however, other times when I press the PLAY button, the level tries to load and it turns black and has 2 joysticks but never loads. It eventually turns back into the main menu.

I have tested both level scripting and level streaming on HTML5 in UE 4.8.3 and did not run into the same issue. Does your game work correctly on another platform, such as Windows? If it does not work properly on Windows, could you upload screenshots of your blueprints pertaining to this issue?

Thanks! :)

avatar image MrDark Feb 24 '16 at 09:48 PM

My game works correctly on Windows (64 bit), Linux and Mac. That's why I'm surprised why it's not working on HTML5. I hope it's possible to do something with it.

avatar image Samantha Sutton ♦♦ STAFF Feb 25 '16 at 02:45 PM

Can you check and see if your project works on mobile preview within the editor? Can you also deploy it to a mobile device and tell me if it works correctly? Mobile devices are closer to HTML5 than other platforms.

Please also upload a screenshot of your level blueprints if you can.

Thanks!

avatar image MrDark Feb 25 '16 at 10:50 PM

On mobile preview it works, but very slowly (way slower than on Windows) and textures and lightning didn't build, so it was all in grey squares.

I tried to deploy it to the mobile version (Android with option "All") and tested it on Samsung Galaxy Tab 2, Galaxy Tab 4 and AndyRoid emulator - but it wasn't working, just black screen - both versions "all-in-one APK" and APK with separate OBB. I used compressed textures, because file cannot be bigger than 2 GB.

I'm sending you screenshots of my level blueprints. I have only 2 levels - menu and the main island, and there's not much code inside. I hope it'll help and we'll find a solution, thank you very much for your interest and support!

avatar image Samantha Sutton ♦♦ STAFF Feb 26 '16 at 02:59 PM

MrDark,

It's very possible that you've created a game that's made more for a PC platform. HTML5 is closely related to mobile devices even though it's ran on a computer, it turns through the browser.

Here is some documentation on Mobile Rendering. Make sure that your project is compatible with opengl ES2. I'd also suggest looking over our Level Documentation. As I do not see your level being called. Do you just have 1 level and a menu screen?

I would also suggest opening a COPY of your project in 4.9 or 4.10 and seeing whether or not you have the same issue as 4.8.3.

Let me know!

avatar image MrDark Feb 28 '16 at 04:35 PM

I've read through the documentation described in Mobile Rendering. I've deleted some elements, removed or modified more advanced materials and set preview rendering level to Mobile/HTML5 (OpenGL ES2). After that my game launched in mobile preview in Unreal Editor worked fine, but still not working as HTML5.

I've downloaded Unreal Engine 4.9.2 and launched a copy of my project. Unfortunately, that doesn't help - game still doesn't work after packaging to HTML5. I'm attaching a screenshot for you and output log.

My level is being loaded after clicking the "Play" button, as seen on attached picture.

I hope it'll help to find a solution.

avatar image Samantha Sutton ♦♦ STAFF Mar 02 '16 at 05:32 PM

Thanks for the updated information. Your issue is still being reviewed, we appreciate your patience. :)

Please let us know if you have any additional questions while we work on the issue at hand.

avatar image Samantha Sutton ♦♦ STAFF Mar 15 '16 at 01:47 PM

MrDark,

Thank you for being so patient during this time. Without the project, it's a bit hard to determine exactly what's happening since we can't enter a break point on the button that's being clicked.

Could you please check to see whether or not cook on the fly was enabled?

It's also beneficial for us to see your project. If you're able to zip it and provide it to me through a PM on the forum, that would be extremely helpful. If you can't provide your actual project, please upload a copy of your project with everything taken out of it except for the menu and the level you're having trouble with.

Thanks!

avatar image MrDark Mar 15 '16 at 11:21 PM

Once again, thank you very much for your concern! Unfortunately, I coudn't find the option you've mentioned.

I'm sending you 2 versions of my project in PM on forum - one without and one with the mobile optimization. First works on UE 4.8, second on UE 4.9.

I hope it will help, I guess I've already used too much of your time, I'm sorry.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

MrDark,

After lengthy testing, I have submitted a bug report to our HTML5 Developer. UE-28490 is the bug which you will reference if you have any questions or want to know the updated status of the bug. I will respond to you once I hear more.

Thanks!

more ▼

answered Mar 16 '16 at 08:25 PM

avatar image Samantha Sutton ♦♦ STAFF May 06 '16 at 08:19 PM

MrDark,

I wanted to let you know that we have not been able to reproduce the error. I changed the OpenLevel to the ThirdPersonExampleTemplate and the level opened up just fine.

Please make sure to run Map Check and have those warnings cleaned up before we look at it again.

  • Main Menu had 2 warnings

  • Spero Island had 1229 warnings

  • and Third Person Example had 14 warnings

Thanks!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question