x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaged Game Crashes after loading widget menu 5 times.

Hi, The packaged version of my project crashes in the main menu screen while loading a widget.

The menu screen works fine initially, but after around 5 visits to the menu screen it crashes. My game has a main menu : widget based - in world) and seems to load fine for the first 4 times the menu screen is loaded. This always seems to happen on the fifth time.

Here is my error :

MachineId:CE2E1A81418B38ECDF553FA484EC6E30 EpicAccountId:7f5de8cece6e488bb1be756133f01eeb

Access violation - code c0000005 (first/second chance not available)

""

CDFStarfighter_Win64_Shipping!FSlateBatchData::CreateRenderBatches() CDFStarfighter_Win64_Shipping!FSlate3DRenderer::DrawWindowToTarget_RenderThread() CDFStarfighter_Win64_Shipping!TGraphTask<`UWidgetComponent::TickComponent'::`20'::EURCMacro_UWidgetComponentRenderToTexture>::ExecuteTask() CDFStarfighter_Win64_Shipping!FTaskThread::ProcessTasks() CDFStarfighter_Win64_Shipping!FTaskThread::ProcessTasksUntilQuit() CDFStarfighter_Win64_Shipping!RenderingThreadMain() CDFStarfighter_Win64_Shipping!FRenderingThread::Run() CDFStarfighter_Win64_Shipping!FRunnableThreadWin::Run()

Any help would be cool, I have been trying to work this out for a while now.

Product Version: UE 4.10
Tags:
more ▼

asked Feb 07 '16 at 02:52 AM in Packaging & Deployment

avatar image

MAGtechnologies
73 4 6 9

avatar image Rudy Q ♦♦ STAFF Feb 09 '16 at 08:17 PM

Hello Swilliams,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints that may be involved with this issue?

avatar image MAGtechnologies Feb 09 '16 at 08:50 PM

Hi Rudy Thanks for the reply.

I have migrated and tried a new clean project and its still the same.

Its something to with the menu widget although everything seems fine with the widget. I have tried placing the blueprint widget in world, and spawning it into the world, I have tried almost everything but it still crashes after around 5 matches when returning to the main menu.

The one thing left to try is to trying it again through the editor (as i had a crash yesterday when recording game play in PIE, and see if i can get the output log for it, but it seems to be the widget, as soon as it loads is crashes (after the 5th time returning to menu)

Aside from that it would probably be best to give you screens of the blueprints and widget set up as im 99.9% sure its to do with the main menu widget. Or i can even send you the widget and relevant assets to test on your side. I can`t put up much stuff here publicly, as I am bound to NDAs, but I can e-mail you them, or upload them to drop box etc.

I will try the editor again as suggested and see if i can get the same crash as yesterday with more details. I will post again shortly with more details on that.

This is the last hurdle and i really need this crash fixing, so thanks for your quick reply and I am hoping to get this nailed by weekend :)

avatar image MAGtechnologies Feb 09 '16 at 10:09 PM

I managed to play through 16 matches through PIE without no crash, so the crash yesterday may have been a spoof. After looking through the output logs there is one thing that sticks out :

LogActor:Warning: GameSession /Game/UEDPIE_0_SFSCRAMm2g.SFSCRAMm2g:PersistentLevel.GameSession_28 has natively added scene component(s), but none of them were set as the actor's RootComponent - picking one arbitrarily LogActor:Warning: GameNetworkManager /Game/UEDPIE_0_SFSCRAMm2g.SFSCRAMm2g:PersistentLevel.GameNetworkManager_28 has natively added scene component(s), but none of them were set as the actor's RootComponent - picking one arbitrarily

This is one of the scramble missions (lots random) but it should not have any network functionality (yet) This sheds any light on it. I also changed the texture mem pool from `1gb to 3gb as ours is a very demanding game and i didn't have a clue it was only using 1gb of the mem graphics until a few days ago. But this hasn't made any change to the crash.

So after more testing i will also look at memory and cpu/gpu usage as the menu works fine x amount of times and then dies off (in packaged game)

avatar image Rudy Q ♦♦ STAFF Feb 10 '16 at 03:22 PM

Hello Swilliams,

I may have been unclear, using your current assets in a new project is not the same as reproducing this issue in a clean project. Could you try to reproduce this issue in a clean project with new assets (in this case a new widget blueprint because you believe this to be the cause of the crash)? If you would like to provide a copy of the project via drop box or google drive you could do so by sending me a private message on the forums. I will then be able to take a closer look and perhaps ascertain more information as to the cause of your issue.

avatar image MAGtechnologies Feb 11 '16 at 07:13 AM

Hi Rudy, I couldn't find how to PM you through here, so i can post links on here.

I have managed to cut most stuff out and have a sample project which you can use to compile and replicate the same issue i am getting. (4.10.2)

There are two maps included, there is a menu map with just the widget, Its set up for controller - left stuck up/down and Bottom face button to select.

Select the scramble mode and its set to load a blank map with some audio, and then returns to main menu after a few seconds. If you do this 5 or 6 times you will get the same crash.

The project is rather big but i have chopped it down so its the bare min so you can load up the project, and compile it on your end. The project also contains some source so you will get a few error, but everything should still work and compile fine.

The download is just under 1gb, I have included the victory plug and and binaries to make sure you have everything you need to get going.

Here is the download Link :

https://www.dropbox.com/s/gx5xd42sgk0syze/TestCDFstarfighter.rar?dl=0

Thanks again for you help on this, I look forward to seeing what you come up with.

thanks,

Shaun :)

avatar image Rudy Q ♦♦ STAFF Feb 11 '16 at 03:35 PM

After downloading the project and running a few tests, I was unable to reproduce this issue on our end. Running the reproduction steps provided did not cause a crash. Could you try reproducing this crash on your end with the project that was provided in the dropbox link? I also noticed that you are using the Victory plugin. As a note, if you cannot reproduce this crash without the Victory plugin you will need to speak with the plugin's creator (Rama). We are unable provide support for 3rd party plugins.

avatar image MAGtechnologies Feb 11 '16 at 03:49 PM

HI Rudy, The crash only happens in packaged game. It doesn't crash from the editor, only a packed/cooked version. Did you try packaging a game and running that?

I will try without the rama victory plugin in the meantime,

Thanks

avatar image MAGtechnologies Feb 11 '16 at 04:14 PM

Hi, I Just tried without the victory plug in and its still crashing after x returns tot the menu.

I am packaging it with shipping/win 64 : Again this only happens in the packaged version. If your packaged version is working fine then it may be something to do with engine when building and cooking. I am using the standard 4.10.2 engine build.

avatar image MAGtechnologies Feb 15 '16 at 10:01 PM

Hi Rudy, Is there any more info on this yet? Did you try packaging and running the packaged game to reproduce this error?

Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Swilliams,

I was able to reproduce this issue with the project provided. I have written up a report ( UE-27010 ) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your information and time.

Make it a great day

more ▼

answered Feb 16 '16 at 08:02 PM

avatar image

Rudy Q ♦♦ STAFF
47.2k 545 132 525

avatar image MAGtechnologies Feb 16 '16 at 09:35 PM

Hi Rudy, that is the last thing i wanted to hear lol, but thanks for trying and your time. I will have to look at an alternative mechanism for the menu in the meantime. Thanks again and I look forward to any updates on this.

avatar image ChrisWood STAFF May 09 '16 at 01:39 PM

This should be fixed in 4.11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question