x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Is there any way to disable self-shadowing?

I have a static mesh which I want to disable the self-shadowing on, problem is that I want it to still have shading and I still want it to cast/receive shadows on/from other objects. (So an unlit material will not work) I just do not want it to cast a self-shadow. I see in the details panel there is a way to enable only self shadowing, but that's the opposite of what I am looking for.

Is there any way to achieve this?

Product Version: UE 4.10
Tags:
more ▼

asked Feb 08 '16 at 11:47 PM in Rendering

avatar image

Arkiras
35 10 13 15

avatar image FilipeTessaro Feb 09 '16 at 12:37 PM

I got a little confused, man...

If you just don´t want it to cast a shadow, just disable: "Cast Shadow"...

or is it the opposite? Cast but not receive?

Please explain

avatar image Arkiras Feb 09 '16 at 01:54 PM

I ONLY want to disable self-shadowing, I want all other shadowing to work as expected.

Disabling cast shadows will not work, because although that will prevent the object from self shadowing, it also prevents it from casting shadows on anything else. Which is not what I want.

I want it to receive shadows from other objects, I want it to cast shadows on other objects, the only thing that I don't want is self-shadowing.

avatar image Tim Hobson ♦♦ STAFF Jul 02 '16 at 03:06 PM

AFAIK self shadowing cannot be disabled. You'll need to workaround it by using a multiply of you base color plugged into the emissive input. Use a low value for the multiply so that it's just enough to crush the self shadowing that happens.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

If your light source mesh can fit in a sphere or capsule then you can use the "Source Radius" and "Source Length" parameters to tell UE4 at what distance to begin 'casting' the light. That will solve your problem for the most part,.

more ▼

answered Jul 02 '16 at 10:20 AM

avatar image

Jin_VE
4.4k 32 77 42

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question