x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

GenerateProjectFiles.bat doesn't recognize Visual Studio 2015

I keep on getting this message:

GenerateProjectFiles ERROR: We couldn't find a valid installation of Visual Studio. This program requires either Visual Studio 2013 or Visual Studio 2012. Ple ase check that you have Visual Studio installed, then verify that the HKEY_LOCAL _MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\12.0\InstallDir (or HKEY_LO CAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\12.0\InstallDir on 32-bit machines) registry value is set. Visual Studio configures this value when it is installed , and this program expects it to be set to the '\Common7\IDE\' sub-folder under a valid Visual Studio installation directory.

I check the intall dir and it is ok. what can i do ? please help

Product Version: UE 4.10
Tags:
more ▼

asked Feb 09 '16 at 12:38 PM in Installation & Setup

avatar image

Diste
26 2 4 5

avatar image Diste Feb 09 '16 at 12:40 PM

alt text this is the screenshot of the installdir

01.png (165.2 kB)
avatar image Doug E ♦♦ STAFF Feb 09 '16 at 01:55 PM

Hey Diste-

Which version of the engine are you trying to compile? Additionally what type of Visual Studio are you using (Express, Community, Pro)? If you are using VS Express, can you instead try Community and let me know if you are still having this issue?

Cheers

Doug Wilson

avatar image Diste Feb 09 '16 at 03:23 PM

I'm trying with UE4 4.10 and i'm using Visual Studio Community yet.

avatar image Doug E ♦♦ STAFF Feb 09 '16 at 03:44 PM

Are you using the Release branch from github to get 4.10 or are you specifically grabbing the 4.10 branch? Did you run Setup.bat prior to GenerateProjectFiles.bat?

avatar image Anatoliy Feb 09 '16 at 04:04 PM

Hi Diste. I think problem in vs2015 in default installation. Try reinstall vs2015 and check in addons to include c++ and all components for him. Default in vs2015 c++ not set to install. I hope it's helpful.

avatar image Diste Feb 09 '16 at 04:10 PM

I'm using the branch from github, and i run Setup.bat prior!

Hi Anatoliy. I'm gonna try to reinstall VS2015, maybe it helps.

Thanks I will let you know.

avatar image Diste Feb 09 '16 at 09:50 PM

Thanks Anatoliy !! That was the problem !!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi to everyone!! I reinstalled vs2015, now everything is fine ! Thank you so much !

Go go go !!

more ▼

answered Feb 09 '16 at 09:48 PM

avatar image

Diste
26 2 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question