x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"Main Menu" Widget doesn't show on Android Device

Hiya :) I am testing a game out that I am making for mobile devices, and I recently just added a Widget for the main menu. The Game starts in an empty "mainmenu" level. In the Level blueprint, I create and add the widget to the viewport.

The actual thing so far looks like this and the buttons have images for "Normal", "Hovered" and "Pressed" inside Appearance -> Style (nobody judge my awesome designing skills! <3) alt text

and the graph for the buttons alt text

So the issue I am running into is kinda weird, and exactly the kinda issues I hoped not to run into... Device specific stuff -_-

I tried sending a build to my phone (Samsung Galaxy Alpha) but it only shows as a white background and grey buttons. On my friends device (Samsung Galaxy S5) it seems to work just fine though..

I'll add some images from the phones tomorrow :) Thank you for your time!

Product Version: UE 4.11 Preview
Tags:
mainmenu.png (737.0 kB)
mainmenugraph.png (49.1 kB)
more ▼

asked Feb 09 '16 at 07:20 PM in Packaging & Deployment

avatar image

Mr-Manly
19 8 8 11

avatar image Mr-Manly Feb 10 '16 at 10:09 AM

So I don't really know what happened, but now the game just loads the splash screen, and then turns pitch black. The controls are still there, just invisible. I can still shoot with my right "stick" and hear the sounds, but not play the game.

avatar image Rudy Q ♦♦ STAFF Feb 11 '16 at 05:58 PM

Hello Beslind,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide the current OS that is running on the device?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Rudy,

I spent the last two days trying to find a way around this issue and no matter what I did, as soon as I added a static mesh in, the game would turn black screen. I scoured through the logs on my phone and found out that there was several shader errors, so I started googling this error instead, and found a guy who had a similar issue saying that it was a thing with 4.11

So I recreated the whole thing in 4.10 and it seems to work fine now :)

more ▼

answered Feb 12 '16 at 08:25 AM

avatar image

Mr-Manly
19 8 8 11

avatar image krisfhugz00 Apr 25 '16 at 05:57 AM

Sir, can you pls make a tutorial for this? I too have that problem

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had the same problem once and it was a problem with the map not the widgets.

I think it was a complex material on my player character that I was using. I can't quite remember.

Here is what I did to fix it. (Again, if I remember right. It was a long time ago.)

Try removing all your default things like player character, game state and such. Then just load the main menu map and widget. If that works, then reinstate each part one by one until you figure out what is causing it.

more ▼

answered Feb 11 '16 at 08:05 PM

avatar image

Parvan
131 5 7 8

avatar image Mr-Manly Feb 12 '16 at 08:27 AM

Hi Parvan, thanks for the reply. I tried your fix yesterday but that did not work. It seems the issue was with the shaders in 4.11 It works perfect in 4.10 :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question