x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

viewmode unlit command not working on packaged project

It's pretty much all in the title. When I execute the console command "viewmode unlit" whether it's on event begin play or on a keypress it works just fine when I'm in the editor but when I package my project it doesn't work at all.

Product Version: UE 4.10
Tags:
more ▼

asked Feb 10 '16 at 07:53 AM in Rendering

avatar image

MuFeR
41 5 9 8

avatar image MuFeR Feb 11 '16 at 07:33 PM

Since it's working when I'm in the editor I just can't find any explanation other than having to change something in the project settings which is unlikely so anyone has any ideas?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey MuFeR,

The viewmodes are in Editor tools that are meant to debug your game/project so when you go to package, it runs as expected and is optimized. This is why we suggest you test in standalone mode and disable 'Realtime' in viewport when debugging for performance in order to closely resemble the final environment.

If you have further questions, please let me know.

Cheers,

Andrew Hurley

more ▼

answered Feb 16 '16 at 03:02 PM

avatar image MuFeR Feb 17 '16 at 01:43 AM

Thanks for the clarification. So is there any other way for everything to look like the "unlit" viewmode? I tried setting all the materials to unlit and connecting the textures to Emissive Color which is close but I still see a small difference between lit and unlit. Same thing as the person reported in this link in his second image.

avatar image AndrewHurley Feb 17 '16 at 02:17 PM

No problem. The hard part about matching the Unlit mode is going to be getting all of your post processing and shadows disabled. Anything that has to do with lighting is going to need to be removed, so all you have are the Base/Diffuse Color contributions from your materials.

You will essentially need to disable your post processing, set all of your materials to Unlit mode, and disable shadow casting. This is going to get you as close to the Unlit mode that I know how to do.

Cheers,

Andrew Hurley

avatar image gustavorios2 Aug 14 '16 at 06:36 AM

but unlit mode has ambient occlusion right? anyways there inst a easier way to do that? I mean.. its so easy on editor. Its kind of strange to have to change all materials, post effects and everything on a higher level when would make so much sense to disable lighting on the render engine at a lower level like the editor do.

avatar image CaptParis000 Aug 16 '16 at 01:14 AM

I'm in a similar position but with detail lighting. Is there definitely no way to force the view mode in the packaged game? I've tried to match detail lighting for a bit now and it's never quite the same.

avatar image AndrewHurley Aug 16 '16 at 04:37 PM

Hey CaptParis000,

Unfortunately the viewmodes are specific to the editor tools and it is going to take some custom setup within your materials and scene to replicate these viewmodes. They are still accessible if you launch using Standalone, PIE, or Play in New Editor Window.

Viewmodes are used as a sort of debugging tool so you can fix things before you package your project. They can also be used to help increase performance when doing things like painting or sculpting a landscape.

Thanks,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The answer is to go to your projects Config Folder and open up DefaultEngine.ini Under the [RenderSettings] or [/Script/Engine.RendererSettings] add the following: r.ForceDebugViewModes=1

Now your viewmode console commands will work in a packaged game.

more ▼

answered Sep 28 '17 at 02:38 AM

avatar image

Davis3D
101 3 9 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question